Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
<- Sums it up
Joined
·
1,739 Posts
Discussion Starter #1
I closely inspected the lifters and I could not find any sign of ware. The lifters look fine but the cam is a different story. What do I do? Does it just go back in or regrind? Or any other direction?
 

Attachments

·
Registered
Joined
·
13 Posts
how many miles cause it could be normal wear. Mic the lobes and check them with the spec. Since you have it out see if it can get reground or even go for a new one. What kind of oil do you use and how's your oil pressure? Just cause there might be some underlying issues you'll want to fix while you have it all apart
 

·
<- Sums it up
Joined
·
1,739 Posts
Discussion Starter #4
what are you looking to do with the truck? That core might be regrindable
Get the pig up and running again. What is the turn around time and cost for one of your stage 1 cams?
 

·
<- Sums it up
Joined
·
1,739 Posts
Discussion Starter #5
how many miles cause it could be normal wear. Mic the lobes and check them with the spec. Since you have it out see if it can get reground or even go for a new one. What kind of oil do you use and how's your oil pressure? Just cause there might be some underlying issues you'll want to fix while you have it all apart
181K miles. Oil has been either Amsoil or Delo. Oil pressure was always fine. Underlying issues will be fixed, I am doing a complete reman on the engine.
 

·
<- Sums it up
Joined
·
1,739 Posts
Discussion Starter #9
1 - 11 of 11 Posts
Top