Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
I just ripped out the interior in my 95 F350 XL Diesel, competely gutted.. installed the new wiring harness from an XLT truck i had cause it had all the built in power options, alarm and keyless entry blah blah blah, I go to start the truck up after i completely installed everything and the truck started right up, had a door open indecator beeping sound that i never had that thought was kinda cool hahaha but the wierd thing is, my AC, heat and all that works, but no light up background, my rpm, fuel guage and odometer works but again no light up background but yet my ABS and parking brake light are on?, my highbeam low beam works along with my wipers but no left or right turn signal or hazards but yet my left and right turning indicator works in the dash?? nor do my power point or cigarette lighter work... but yet my glove box light works when its open.. everything that doesnt work I no for a fact I hooked up.. everythings a plug in deal.
 

·
Demon Dually
Joined
·
5,140 Posts
Sounds like a loose or disconnected ground. I would go over every harness and wire you can get at and look carefully for a loose, disconnected, or missing ground wire.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
I believe there is only 2 grounds for the interior wiring harness, I could be wrong but I remember bolting them to the passenger and driver side kick panels.
 

·
PMS medication required
Joined
·
455 Posts
It seems to me that there should be more to it than just the wiring inside the cab? Shouldn't there also be additional wiring going through the FW? BTW how hard is it to take the whole dash apart to get to all the wiring?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
the interior wiring harness and the engine compartment wiring harness plug into eachother, the harness thats in the truck now came from a 96, and mine is a 95.. both were identical but the year.

dash is fairly simple to remove unbolt and unplug.
 

·
Demon Dually
Joined
·
5,140 Posts
Perhaps there was a pinout change between the model years or maybe a change in pinout due to the xlt ve xl difference as in power windows/locks/seats etc..
 
1 - 6 of 6 Posts
Top