Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hey guys, was driving home the one night (2004 F-250) and my WIF light came on, didnt have a way to open the HFCM to drain it out. In the morning i got my allan wrench and moved to open the drain, only problem is it is rusted / siezed and dispite my best efforts the drain wont budge, almost to the point the hole started to strip, I know i definitely need to drain this thing out if there is water, but after one or two days of driving, the WIF light now seems to be coming on intermittenly and shutting off intermittenly at different intervals, is it the sensor going bad, or water in the fuel or a combo of both, Probably will wind up replacing the HFCM filter while im at it aswell.
 

·
War Pig
Joined
·
618 Posts
I would just take off the cap and change the filter. That should get any water out and you'll have a clean filter to boot. After that you'll know if you have a bad sensor.
 

·
6Leaker
Joined
·
6,719 Posts
When I messed with mine last changing the filter wasn't good enough and the sensor was still good. But the previous owner had never drained it out, and it was frozen to the cover before I got to it, so I think about 65k worth of miles with it never getting drained...

Ended up pulling the pump off the rain (really easy after you do it the first time, 10 minutes maybe)

Had all this gunk sitting on the bottom and is what was causing the sensor to come on.





Cleaning it out and drilled the frozen plug out and replaced it with the newer hand thread in plug and its been good since.
 

·
Registered
Joined
·
140 Posts
Mine did that. WIF light would come on and off intermittently. I went aheas and changed the filter and sensor after repeatedely draining it. No problems since. The sensor cost me about 15 bucks at Ford.
 

·
Diesel Sled Head
Joined
·
1,101 Posts
Or tap it with a hammer first then they will usually turn out...
 
1 - 8 of 8 Posts
Top