Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
All Right I got a problem, When I start my truck and its cold it runs okay im just really down on power. Once my truck starts to heat up the oil though, my engine starts losing power Fast, my the time my coolant gauge gets halfway to the N in normal im barely able to drive it, The engine is extremely unbalenced and i almost get "puffs" of black smoke and i can barely maintain 30 mph. It has gotten to the point that i cant even raise my rpm above idle even in neutral. Egt is hotter than normal but never above 1000 degrees, I just barely replaced the CPS, and the CPR fuel system and Adrenaline HPOP are under 4 months old.

From what i can tell it is directly related to oil temperature with how well it runs. The only idea i can think of is my IPR.
 

·
Registered
Joined
·
3,033 Posts
You might need new IPR o-rings or even new injector o-rings. Hot oil will "bypass" bad o-rings easier than cold. The IPR o-rings are only about $30, so that's a fairly cheap try. You can remove the valvecovers and see if oil is coming out around the base of the injectors while running. Cheers!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Thanks patrick ill look into that, a New IPR will come with new O rings correct?

QUOTE=diesel_brad;1709784]When is the last time you changed the oil?[/QUOTE]

Changed oil Little over 2,000 miles ago.
 

·
Registered
Joined
·
435 Posts
Thanks patrick ill look into that, a New IPR will come with new O rings correct?

QUOTE=diesel_brad;1709784]When is the last time you changed the oil?
Changed oil Little over 2,000 miles ago.[/QUOTE]

Yes, new IPR's will have new orings.
 
1 - 5 of 5 Posts
Top