Ford Power Stroke Nation banner

1 - 18 of 18 Posts

·
I know nothing...
Joined
·
6,115 Posts
Discussion Starter #1
I put a TS custom chip on last summer. At 1st it seemed like it gave me something, mostly better shifting. But now that my oil situation is better the chip is useless. It still sounds and shifts differently but has 0 affect on power.
I ran 1st with chip on stock then on street strip, the 6thpos runs like dogsh!t.



I'm not putting anyone or anything down just trying to figure out why mine doesn't give the boost in HP you all claim to get. I've read that the 96' was an in-between year. Could I have the wrong chip? Any input would be greatly apreciated.
 

·
I know nothing...
Joined
·
6,115 Posts
Discussion Starter #4
That's prolly what I'll do after stg1's and adren. I have just been critical of the chip and was wondering if it was just a bad 1. Should have noticed some improvement on the 0-60 times right?
 

·
Registered
Joined
·
2,448 Posts
I don't know that I saw a difference at idle, but the whole range had tons more power. I would send it back for a reburn.
Are you sure you got the calibration right? 96 had some cali trucks that had AB's, but looking at your location, I doubt that's a problem....
Edit: if It was, you would have a sticker on your passenger valve cover (I think) that says something along the lines of "Emissions systems on Board"
Do you have boost or EGT gauges?
 

·
I know nothing...
Joined
·
6,115 Posts
Discussion Starter #7
I don't know that I saw a difference at idle, but the whole range had tons more power. I would send it back for a reburn.
Are you sure you got the calibration right? 96 had some cali trucks that had AB's, but looking at your location, I doubt that's a problem....
Edit: if It was, you would have a sticker on your passenger valve cover (I think) that says something along the lines of "Emissions systems on Board"
Do you have boost or EGT gauges?
I'll look for that, no boost or egt.
 

·
What else?
Joined
·
4,156 Posts
That's prolly what I'll do after stg1's and adren. I have just been critical of the chip and was wondering if it was just a bad 1. Should have noticed some improvement on the 0-60 times right?
If you say it runs like crap now, why would you wait to get it reburned?

What tunes do you have?

Dave
 

·
What else?
Joined
·
4,156 Posts
I don't know that I saw a difference at idle, but the whole range had tons more power. I would send it back for a reburn.
Are you sure you got the calibration right? 96 had some cali trucks that had AB's, but looking at your location, I doubt that's a problem....
Edit: if It was, you would have a sticker on your passenger valve cover (I think) that says something along the lines of "Emissions systems on Board"
Do you have boost or EGT gauges?
I've seen 2 Cali OBS trucks here in Ohio, so I wouldn't say it couldn't be one. It very well could be one, he'd have to check the calibration number to know for sure.

Dave
 

·
Village Idiot
Joined
·
8,209 Posts
Actually in top setting my rpms drop about 70 at idle.
Can't say my shifting improved the first go around.
In top setting everyonce and a while i'd get a hard shift.
Like shake the truck hard. First time I thought a honda rear ended me...lol
 

·
I know nothing...
Joined
·
6,115 Posts
Discussion Starter #11
Tunes are:
1. No start
2. Stock
3. Tow
4. Heavy tow
5. Street/strip
6. All out

It barely run at all in 6 and 0 diff in the rest except shift points.

I haven't gone for reburn because I'm getting sticks and big oil this spring.
 

·
Registered
Joined
·
2,448 Posts
Why did you link to the thread we're in??
 

·
The Fireman
Joined
·
4,810 Posts
Why did you link to the thread we're in??
:doh: for some reason I was thinking it was a new thread because when i clicked on it it took me to here and didnt see that it was the 2nd page LOL

I'm not with it at all today
 

·
The Fireman
Joined
·
4,810 Posts
1 - 18 of 18 Posts
Top