Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
So nearly 3 weeks ago, I installed the DDM Tuning 35w HID kit in my '07 F250. I went with 5000k in the headlights (9008 bulb setup) and 6000k in the fog lights. I also spent a bit extra to get the "upgraded" slim digital ballast. Since day 1, the fogs and headlights will not work properly. My passenger side headlight will not come on sometimes, and when I go from low to high beam (which is a joke) then back to low, my passenger side light stays hung up in high beam, until I cut my fogs off. Every time without fail, my fog light on the driver side will not come on unless I toggle the switch back & forth 6 or 7 times. The fog lights are what makes this setup. I emailed ddm, and they gave me a long spill about me being charged for sending components back if they test them as working properly, etc... What gives PSN?
 

·
Registered
Joined
·
868 Posts
Mine in my 05 from DDM work great. And have been for like 8 months. Did you install the upgraded harness with relays?

Sent from my DROID RAZR using AutoGuide.Com Free App
 

·
Registered
Joined
·
868 Posts
I've heard of many problems with hids in the fogs with no harness. I'm sure that will take care of your problem

Sent from my DROID RAZR using AutoGuide.Com Free App
 

·
Registered
Joined
·
255 Posts
I highly recommend having relay harnesses for all hid kits I have also been running the ddm tuning ballasts for years with out issues
 
1 - 6 of 6 Posts
Top