Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
2003 6.0, had no power or boost at low rpm, above 2500rpm at WOT
it would build boost and make power. Unplugged EBP and truck runs like a beast. Will it hurt to run it unplugged for a day or so .
 

·
Registered
Joined
·
218 Posts
No, it wont hurt anything. I ran mine like that for a little while as I was trouble shooting an EBP problem. More than likely, your tube is just clogged with soot. Clean it out and you should be good to go.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Thanks for the info!
 

·
Registered
Joined
·
218 Posts
Keep something in mind though. when I had an EBP problem, I had issues that where opposite of what your experiencing. My low power was fine, I just had a hesitation on higher RPM's and pulling up a grade.
 

·
Registered
Joined
·
1 Posts
Keep something in mind though. when I had an EBP problem, I had issues that where opposite of what your experiencing. My low power was fine, I just had a hesitation on higher RPM's and pulling up a grade.
Keep something in mind though. when I had an EBP problem, I had issues that where opposite of what your experiencing. My low power was fine, I just had a hesitation on higher RPM's and pulling up a grade.
What other problems did you have when I unplug mine it still reads 6.5
 

·
"resident smarty pants"
Joined
·
4,356 Posts
Wheehop hasn't been seen for 3 years

Sounds like a bad EBP sensor. Can you post the units for that reading (I mean psia, psig, kpa, in H20, in Hg, etc)
 
1 - 6 of 6 Posts
Top