Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
If I'm posting in the wrong place let me know. Newbe to the diesel world so I messed up... I changed the o rings on my injectors because there was oil in the fule filter. Found the bad o ring but also replaced the o rings on all the other injectors as well....didnt watch the whole youtube vidio.... Hydrolocked my 7.3 and cranked it over twice for about 5 seconds. On the second try there was a grinding noise that sounded like rocks being slid/crushed between a metal table and a steel plate. The sound was about a second long and I did stop turning the key when i heard it. I removed the injectors again and the glow plugs and it will no longer turn over. It only clicks when I turn the key. I had 12.8v on the batteries and hooked up a charger to them so i know it's not a drained batterie. Any ideas whats wrong with it? Its a OBS 7.3.
 

·
Administrator
Joined
·
58 Posts
sounds like the starter took a crap.
have you tried putting a breaker bar to the crank bolt with injectors and glow plugs removed?
 

·
Registered
Joined
·
6,235 Posts
Did you have fuel/oil in the cylinders when you removed the injectors the second time?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Did you have fuel/oil in the cylinders when you removed the injectors the second time?
I'm assuming so because I didn't get it out the first time. I havent been able to turn the motor over to blow out anything either so i wouldn't know from that too.
 

·
Registered
Joined
·
6,235 Posts
You need to try the breaker bar with the injectors and or glow plugs removed and as you turn the engine over have someone watch to see if there is fluid coming out of one of the holes.

Cut O rings happen when you are reinstalling injectors. When you pulled the injectors back out did you see any problems with the O rings?
 
1 - 6 of 6 Posts
Top