Ford Power Stroke Nation banner

1 - 10 of 10 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
So last night my trucks fan hit my transmission line and the line bursted and sprayed transmission fluid all over the motor. And I believe it got into the turbo as the intake pipe was wet. Now the turbo makes a screeching sound when put in drive or reverse. It doesn't do it when it is in park or neutral. Does it need to be rebuilt or will this noise go away after a while? It's the stock turbo.
 

·
Trust me, I got this...
Joined
·
1,289 Posts
Are you sure the wetness is tranny fluid and not oil from the ccv? The screeching seems like it has something to do with your trans not the turbo. If you can rev it in neutral and the turbo doesnt screech like you say, then its probably not the turbo. Were you doing this after the lines just blew and spilled alot of your trans fluid out?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
It's red inside the intake tube towards the bottom. The air filter had atf on it. I don't think I damaged the trans it only moved about 30 feet then I shut the truck off


Sent from my iPhone using Tapatalk
 

·
Trust me, I got this...
Joined
·
1,289 Posts
Well the atf itself shouldnt hurt the turbo, but the fact that you heard a screeching only when in a moving gear (drive and reverse) and not in park or neutral seems like a strong indication that it was your transmission not the turbo.

I would clean/replace the air filter, replace those lines and put some new atf in your trans and then see what happens.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #5
I put new fluid in today along with the lines and started it up without the filter and just putting it in drive it was still doing it but wasn't as loud


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3,357 Posts
noise is not there in N only in D?
Does truck drive and shift just with a noise?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #8
Found out it's just a pulley. When under load it's making a noise


Sent from my iPhone using Tapatalk
 
1 - 10 of 10 Posts
Top