Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Master of Disaster
Joined
·
68 Posts
Discussion Starter #1
So i cleaned my turbo, all mechanical parts were in good working order and re assembled it with no issues. It ran fine for a while then started turbo farting off and on. So today i put in a brand new VGT solenoid and it doesnt stutter or fart as bad but still does it occasionally. So i towed today and it was a lot worse when i was towing. It does it sometimes when your on the throttle or letting off. Took the trailer off and drove the crap out of it unloaded for 60 miles and didnt have any problems. Any ideas what it could be?

Thanks!

Wade
 

·
Registered
Joined
·
4 Posts
when the converter is locked and you roll into the throttle to accel without downshifting. does the boost climb then stick and start to fall and the turbo bark? does it do it more if the motor is hot atleast 15 min of driving?
 

·
Registered
Joined
·
186 Posts
Thats interesting. I have been chasing the same problem since May of this year!!! Not that I can give you any good advice, but I have replaced almost ever part/sensor(turbo,intercooler,up pipes,egr delete, map sens,maf sens,icp,ebp,etc.) possible I think. And still have the same problem.
With that said check your ebp sensor and the tube it can plug, also check the map sensor and hose they can plugg too.
Let me know if/what fixes your issue if you would
 

·
Registered
Joined
·
186 Posts
True, I never noticed the year, the turbo may be on its way out.
 

·
Registered
Joined
·
368 Posts
take for what its worth,but a notable tuner told me the pcm still used the ebp sensor anyways...i never understood was why it still had to be there and hooked up if its not used? its not a big deal to clean,id give it a shot.
 
1 - 7 of 7 Posts
Top