Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
6.0stroker250
Joined
·
21 Posts
Discussion Starter #1
I was accelaerating up to 55mph and when i was my turbo was backspooling like crazy!?!?!?!?!?!? It was cutting in and out dont know what it would be???
Also my truck blows blue smoke when it is warm. it only blows the blue smoke when i am accelarating like around 2000 grand and it bogs the motor down to!?!?!?! dont know what that would be either its a 05 6.0 all stock with 102000 miles
 

·
Registered
Joined
·
3,600 Posts
So the compressor was surging? Have you looked on your dash to check boost when it does this, sounds like the turbo veins are stuck. The bluish smoke is likely to be oil, it's burnin oil somewhere.
 

·
6.0stroker250
Joined
·
21 Posts
Discussion Starter #3
It was doing it at like 20 pounds a boost. like when it does back spool and goes choo when u left off well when i was accelerating it was going choo choo choo over and over....and with the blue smoke i had that problem when i bought and one day the egr took a #### coolant was getting into the exhaust the dealer said????
 

·
PSN Veteran
Joined
·
2,983 Posts
Pull your EGR valve and clean it and check it and the manifold for moisture. When your building boost then let off the choo choo sound I believe is called a turbo fart, since our turbos aren't wastegated all that air is trying to go back out the intake. Now for the choo choo sound when building boost not really sure.
 

·
Master of Disaster
Joined
·
68 Posts
Sounds like your VGT solenoid is going out
 

·
6.0stroker250
Joined
·
21 Posts
Discussion Starter #8
Yea it might be the exhaust....and i will have to check the egr just gata find someone around wisconsin that knows how to work on the 6.0.....another thing is i really dont have the money for the egr delete and studs so i just might end up selling the dam thing
 
1 - 9 of 9 Posts
Top