Ford Power Stroke Nation banner

1 - 10 of 10 Posts

·
Registered
Joined
·
620 Posts
Discussion Starter #1
ok guys, got a weird one here. My truck is a 2002 f250 ccsb 7.3 at, recent repairs include two new batteries, cps, repaired all wires going to alternator, every o-ring in the fuel system, and a n oil change. Yesterday i was driving to work and the truck jerked on me going down the interstate. thought that was weird. Also my battery light has been flickering. On my way home yesterday came to a stop and she died on me. no CEL. Put it in neutral and it started right up. It jerked a few times on the way home. battery light still flickering. Same story today except i fixed the battery light flickering by repairing the alt wires and i unhooked my sub. i also put a new cps in this morning. On my way home it died on me again no CEL. Anybody have any ideas cause i can't think of any. My ebps is broken but i don't think that that would shut her down, especially with no CEL. Also my truck does have a bully dog 6 pos chip. I always run the 85hp tune. Any help would be appreciated.
 

·
Registered
Joined
·
245 Posts
Have you had the electrical system load tested?
Check the batteries key off and then again with the engine running.
These trucks hate low voltage and charging issues.
Check the UVCH for chaffing.
 

·
Village Idiot
Joined
·
8,209 Posts
my alt died truck was very strange until it finally petered out, new one lasted 1 day, replaced all is well.

alt, cps, cand be buggers to trace down because newones from advance etc can be broken right out of the box.
 

·
Registered
Joined
·
182 Posts
Yeah I would look at the alt also. Like southmike said, it acted really weird till it left me stranded out in the field.
 

·
Registered
Joined
·
620 Posts
Discussion Starter #5
ok, thanks for the input. I drove it yesterday with no issues. i guess i will just see what happens and i will plan on replacing the alt when i free up some cash
 

·
green037.3
Joined
·
49 Posts
I had a 1999 superduty 7.3 that had rubbed the main harness coming into the cab on the steering shaft everyonce and a while you would be driving down the road and it die then start right back up. Would only do it everyonce and a while.
 

·
COMPUTER BLUE
Joined
·
1,979 Posts
I would also look into cps I had a bunch from Napa etc and they kept crapping out on me but when I switched to a ford one I had no more problems
 

·
Old Yeller, REBORN
Joined
·
2,284 Posts
You say it started in neutral. What about a park/safety switch going out? Not even sure where it is but may be something to look at.
 

·
Village Idiot
Joined
·
8,209 Posts
My cps and alt both took years to finally die...
Cps was vintage 99 and was perfect till last two years, one or two random shut downs thrn six in the last month. Alt was the same nine years two weird stalls, funky pcm code errors.. Then one day in the boonies. The batt light came on and it was dead.
 
1 - 10 of 10 Posts
Top