Ford Power Stroke Nation banner

1 - 20 of 21 Posts

·
Registered
Joined
·
499 Posts
Discussion Starter #1
This might be long so sorry. I got my DP F5 chip installed and took the truck out to test it. When I was in stock mode everything was fine. When I tested position 2 (60 Tow) the truck ran great but when I would slow down almost to a stop and push the clutch in the truck would die, not every time but a few times. On Pos 3 (80 economy) the truck would die almost every time I slowed down to stop and pushed in the clutch. I didn't test the other two Positions. I called and talked to Jody at DP, he was absolutely helpful and told me to check the IPR I pulled the IPR and disassembled it and cleaned it as the posted on PSN. I also pulled the ICP and cleaned it. and changed the oil and filter. The truck then ran fine for about a week until today, On Pos 3 (80 econ) I went to stop at an intersection and pushed in the clutch and the truck died. Luckily I could get it stopped without smacking the car in front of me. I'm worried to drive with the tunes on now don't want to rear-end someone. What should I check, is my ICP or IPR bad if so which one and how do I test them? Could it be anything else like my HPOP, I just recently pulled my HPOP and put all new o-rings in it. I'm getting ready for a 200 mile trip tomorrow so any help would be greatly appreciated.:confused:
 

·
Village Idiot
Joined
·
8,209 Posts
didn't loose those small check valve balls did you ,(when you pulled hpop)?
hpop could always stand to be replaced w something besides a 15°
but short of someone with ae or a scan gauge or sending to be bench tested ,which dieselsite is the only shop i know that that has one.

you could call jody and make sure he has the correct mods listed for your truck...ie he doesn't have big oil tunes on your ol 15.
 

·
Registered
Joined
·
499 Posts
Discussion Starter #3
Ive talked to Jody a few times, he has checked and double checked the tunes they are correct for the truck with a 15* pump. I disasembled the HPOP on my kitchen table, put it back together same as it came apart, so don't think I lost the check balls, but if you could refresh my memory on where they are located. I don't have the $$ for a new HPOP right now especially not if I can do it with a ICP or IPR replacement.
 

·
Registered
Joined
·
499 Posts
Discussion Starter #4
Also I had my CPS replaced at the dealership a few months ago under recall, if they put the crappy one it can't remember if it the grey of black one could this be my problem.
 

·
Registered
Joined
·
324 Posts
Does it run fine without the chip, if so it is the tuning, or your connection to the chip.
 

·
Village Idiot
Joined
·
8,209 Posts
Maybe pm joey at terminator or bob at dieselsite, better yet email them.
Both are very helpful and know hpop issues inside and out. They are both pretty busy but well worth the wait. Pulling the chip with keys out may be a good start. Thou I am sure programing calls for more from everything so could be ipr, hpop . What was the need for taking the hpop apart something blow or strip out?
 

·
Registered
Joined
·
499 Posts
Discussion Starter #7
Took the HPOP to put new o-rings and serviceable plug in, I had a small oil leak there. The truck runs great on the stock setting of the chip and only dies every once in a while when I'm on the second setting and then it increases as I go up in programs. Jody said the programs requires more oil on those setting and when the truck slows down and rpm drop the IPR isn't reading the change quick or accurately enough which causes the pressure to drop and the motor dies.
 

·
Village Idiot
Joined
·
8,209 Posts
You could try to clean yours again ,Beg borrow steal another.
 

·
Registered
Joined
·
499 Posts
Discussion Starter #9
I know I hate to buy one but I might not have a choice. I will pull it again and clean it. I wouldn't mind buying one or the other I just don't want to by a ICP and IPR. is there a way to test them?
 

·
Registered
Joined
·
499 Posts
Discussion Starter #10
After looking at Guzzles website, It sounds like it could be the CPS I have the chip out now and I am seeing the rpm's drop to around 500 or a little below every once in a while while driving.
Is there a way to test the HPOP without sending it off? The truck is a daily dirver and it can't be down for that long.
 

·
Registered
Joined
·
4,865 Posts

·
Registered
Joined
·
499 Posts
Discussion Starter #12
thanks TARM I will try to get that done this weekend
 

·
Registered
Joined
·
499 Posts
Discussion Starter #13
Well I have to work this weekend and had to put brakes on the wifes car today instead of working on my truck. Anyway, after reading some other threads I put my tuner back on and started my truck, I unplugged the ICP and the truck started idling better. I took it out for a spin and on setting three which is 80 econ the rpms stayed about 3 hundred higher than they were before when down shifting and slowing down to stop. The truck didn't die one time. So am I right to assume my ICP is bad?

thanks for any help
 

·
Registered
Joined
·
499 Posts
Discussion Starter #14
Well I put the new ICP in which is the bigger nut style, I took the truck to town and it runs worse than it did with the old ICP. It will die on every setting on my tuner now even stock, and when I am going down the road at about 60 mph and push on the throttle It feels like there isn't much power. Is this an ICP problem or something else? With my old ICP the truck won't die in stock mode just the others, when I unplug the ICP truck runs great and won't die in any setting. Did I get a bad ICP? Please help I have a 1k trip in two weeks and I need my truck running right.
 

·
Village Idiot
Joined
·
8,209 Posts
Id ask joey at term or bob at dieselsite, I have found that they are pretty helpful and know the hpop & related things inside and out.
 

·
Registered
Joined
·
499 Posts
Discussion Starter #16
Does the ICP tell the pcm to control the HPOP? How does the HPOP ICP and IPR all relate and communicate with each other to control oil pressure to the injectors? I can understand if my HPOP is getting weak the higher tunes not working, but with the new ICP the stock setting is dying. I will unplug the ICP sensor tomorrow on the way to work and see if it runs better like before. If it does what is my next step, return the ICP and ask for new one? Will it hurt anything to run the truck with the ICP unplugged until I get the problem fixed?
 

·
Registered
Joined
·
499 Posts
Discussion Starter #17
I talked to Jody at DP, he thinks the new ICP is bad any thoughts??
 

·
Registered
Joined
·
499 Posts
Discussion Starter #18
I unplugged the ICP sensor and the truck still runs much better on default. I can run my tunes and it won't die. What do I need to check or did I just get a bad ICP. Any suggestions would be really appreciated, I am at a loss as what to do next.
 

·
Registered
Joined
·
499 Posts
Discussion Starter #19
BUMP, anybody?
 

·
Village Idiot
Joined
·
8,209 Posts
Echange the icp..I went through 3 bad autozone water trmp sensors only to find oem ford
A.) Worked better and to my surprise b) was cheaper....doh
But as far as cps goes they are recalled so ford will swap a new one in free, not they are better so try and get your old one back. So are some say they got a worse one ..but free is free. Id still ask bob or joey to be sure, if anything they can send you a tested known good unit.
 
1 - 20 of 21 Posts
Top