Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, New to the site need help badly. My truck is a 2000 F 450 7.3 4x4 automatic regular cab with 182k. The problem is the truck will stall or sputter while driving. Then it will blow the number 5 fuse. After that will run perfect. No issue whatsoever except the alternator wont function properly. When I put in a new fuse it will charge but wont run more than ten minutes without blowing the same fuse. When truck sputters but doesn't stall check engine light comes on. When shut off and restarted no cel. Had a shop put on scanner got nothing. Please help truck is a necessity on the farm everyday. Thanks Dan.
 

·
Registered
Joined
·
271 Posts
Does this truck have single or dual alternators?
What size fuse is in the #5 slot?

From a quick look at the diagram (and not knowing the above), here is a guess. If the alternator is bad, it could be dragging down it's 12v supply which also supplies power to the IDM and ECM relays. When the voltage is pulled down too low, the IDM and ECM could also have low voltage and cause running problems. For this theory to work, I would say the fuse in #5 would have to be way too big also.

EDIT: I'd also like to know what size fuses are in slot 6 and 7.
 

·
Registered
Joined
·
44 Posts
Get a volt meter and start the truck and read the voltage on the batteries... A bad alternator overcharging could cause this And make the truck do weird things...the alternator in my wife's car was bad and overcharging the battery at 20v (should be 12v-13v while engine is running) and making the car do all kinds of weird things.. An alternator over charging can destroy batteries...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
It is a red fuse 15 amp fuse I believe. It has a single alternator, that was replaced a couple of months ago. Also new batteries at that time. The control wire that went to alternator was bad and killed alternator and batteries. It did stall out last winter when my guy was plowing but never did it to me. Figured he just smashed into snow banks too rough.
 
1 - 4 of 4 Posts
Top