Ford Power Stroke Nation banner

1 - 20 of 20 Posts

·
Registered
Joined
·
1,734 Posts
Discussion Starter #1
Ok well last night I was pulling onto the highway and I had my extreme race tune loaded up. Well I was into it at about 1/2 to 3/4 throttle to get up to speed and once I hit about 4th I could tell it started to slip which it has never done before. Once it did that I let off trying to get it to grab but when I gave it some gas it just free revved like it was in neutral. Well I pulled into a driveway to turn around and go back to my house and I put it in reverse and I couldn't to get it to move at all so I shut it off and waited a couple minutes and I couldn't get it to go in reverse but when I went forward it was like it was taking off in 5th gear. Well before I even made it a mile down the road it wouldn't grab so I coasted into my neighborhood. Well when I got there i put it on my tow tune just to go almost back to stock cause I didn't wan to wait for the stock file to load. Well when I got it loaded up I took a drive around the neighbor hood and everything seemed find until the tow/haul light started flashing. I made it back to my driveway and when I put it in reverse to back in my spot I couldn't even get it to move. I shut it off and let it sit for a minute or two and I finally got it backed into it's spot. I checked the fluid and it was at the right level it was also a little dark and It pretty much smelled burnt. I also had a check engine light pop up.

Here's the code.



Any help is appreciated!

Thanks!
Matt
 

·
Registered
Joined
·
1,734 Posts
Discussion Starter #2
Also the transmission temp Never even got above 180 degrees.
 

·
Registered
Joined
·
177 Posts
I don't have a good answer for you but I thought I would let you know mine did that this winter coming into town in 4 wheel drive. Had it towed to the tranny shop they pulled the codes same codes as you are showing. Cleared the codes and redrove it. No problems 5000 miles since never had it do it again. Good luck.
 

·
Registered
Joined
·
1,734 Posts
Discussion Starter #4
Well I erased the code last night and I'm fixing to put it completely back to stock. Hopefully I can get some filters and some tranny fluid today but I was told that you can only get it at ford.
 

·
Registered
Joined
·
1,734 Posts
Discussion Starter #5
Ok I put it back to stock and when you put it in forward or reverse it will jerk a little bit. Everything shifts fine until to get to about 55-60 and it won't shift into 5th gear. Plus the tow/haul light is still flashing.

Any Ideas?
 

·
Stroken it 7.3,6.0,6.4
Joined
·
1,239 Posts
I think one of your solenoids is sticking.
 

·
Registered
Joined
·
1,734 Posts
Discussion Starter #7
With the check engine code its throwing would it be solenoid B?
 

·
Registered
Joined
·
13 Posts
Best thing to do is pull the valve body down and air chk your piston's most likly you blew the coast clutch piston, sounds like a tear down and overhaul.
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
When was the last time your transmission was serviced?
 

·
Everybody poops <~ see?
Joined
·
615 Posts
Mine had a very similar condition a while ago, IIRC I had a P0757; shift solenoid 2 performance - stuck on. Dropped the pan, r/r'd the solenoid in question, new fluid and filter, enjoyed.
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Take it to Ford and get the transmission flushed.
 

·
Everybody poops <~ see?
Joined
·
615 Posts
Take it to Ford and get the transmission flushed.
Drive it to the dealer, and potentialy cause more damage? Secondly, if there is internal 'hard parts' damage, a fluid flush is a guaranteed way to disperse the tiny metal parts evenly throughout the transmission. Want to pay for an overhaul, then make your appointment at that Ford dealer.
 

·
Registered
Joined
·
1,734 Posts
Discussion Starter #14
Heres the external filter.



And here's what ran out of the internal filter.



There was at least that much metal in the pan.
 

·
Everybody poops <~ see?
Joined
·
615 Posts
Sorry to say, you're phucked. Those metal shards were part of your L/R, or direct hub and drum assembly. Is your trans still under factory driveline warranty?
 

·
Registered
Joined
·
2,269 Posts
sun coast time, when mine goes i thinking about getting their over haul kit.
looks like yours is done man sorry.
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Dang dude, you can't seem to catch a break. Contact Kevin (RescueF250) and he can get you in touch with a local guy near him that builds great transmissions at great prices. Wither that, or rebuild yours with a SunCoast kit and a SunCoast TC ($$$).

Next time, be sure to keep up with the transmission service. Also, I wouldn't drive in the Xtreme Race tune daily. I would stick to Xtreme Street.
 

·
Registered
Joined
·
1,734 Posts
Discussion Starter #18
It's got 142k miles on it....its way out of warranty. I'm probly gonna send it to Doug @ GoGo diesel and he will go through it and beef it up a little bit.
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Good choice. :D
 

·
Haters Gonna Hate
Joined
·
5,869 Posts
It's got 142k miles on it....its way out of warranty. I'm probly gonna send it to Doug @ GoGo diesel and he will go through it and beef it up a little bit.
I'm guna have to start gettin some comission on this sh*t haha
 
1 - 20 of 20 Posts
Top