Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Tonight on the way home from work as i pulled on to the interstate my Transmission temp gauge maxed out and my tow/haul light started to blink. The handling did not change at all and there was nothing out of the ordinary. I pulled over and checked the fluid level and looked for any leaks under the truck but fluid was full and no sign of any leaks. As I was checking the fluid level the gauges went back to normal. So I got back on the interstate and it was fine for about 5 miles and the gauge and light went back to maxed out and blinking.

Any suggestions?????
 

·
Registered
Joined
·
1,434 Posts
What gauges?

My isspro did the same thing..would just max out all of a sudden and jump all over the place. Traced it back to a bad connection at the distrib box or whatever it is.

As for the blinking tow/haul light..??
 

·
Transmission Junkie
Joined
·
197 Posts
It sounds like you need to get it to a shop and check the codes. The torque converter may not be locking. Torque converters are what create heat in the transmission, when they are locked the transmission temp stabilizes. If the converter doesn't lock the transmission cooler system cannot do its job. That would be the first place that I would look.
 

·
Registered
Joined
·
2,438 Posts
cooler may be plugged up for stuff coming apart inside thats what mine did when it went ouy back flush the cooler in to a Jar and see all the junk in it.
 

·
Former Ford Trans Engr.
Joined
·
3,062 Posts
Are you referring to the stock gauge? If so, most likely your TFT sensor and/or the wiring harness to it has failed. It's not uncommon, and it isn't difficult to change. It is inside the pan.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Yeah the gauges i mentioned were the stock gauges. This morning on the way to work everything was normal for the first 10 miles but the issue resurfaced just before i made it the 15 mile complete trip. As i said the truck does not seem to have any difference in the way it handles, just the trans gauge maxes out, "check gauge" light is on and "tow/haul" light blinks.
 

·
Transmission Junkie
Joined
·
197 Posts
if nothing changes on the truck I would check the gauge or wiring like stated earlier...
 

·
Former Ford Trans Engr.
Joined
·
3,062 Posts
It isn't the gauge. It is the trans fluid temp sensor or the wiring to the sensor inside the pan, or it's both.
 

·
Transmission Junkie
Joined
·
197 Posts
It isn't the gauge. It is the trans fluid temp sensor or the wiring to the sensor inside the pan, or it's both.
Thats what I meant... sorry. The sensor and the wiring harness. Ive had to change the harness a couple of times on trucks, especially on snow plow trucks that get snow all packed up in there.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #10
NEW Issue!!

So today on the way home from work the truck was running fine then i made a stop and when i took off the truck would not shift out of 3rd, which made it difficult since i was on the interstate. will changing the sensor correct this problem????
 

·
Registered
Joined
·
486 Posts
If your OD light was flashing when you tried to go, stuck in third, it sounds like your tranny is in limp mode and may have some major issues. Im not sure what tranny you have but either way you HAVE to get your hands on a scan tool capable of reading tranny codes. When my 4R100 $hit on me it took a matter of minutes before my stock temp gauge maxed out cruising down the highway. Suncoast cracked it open and my 2nd and 3rd gear clutches where done. The scan tool will help pin point whats going on.
 
1 - 11 of 11 Posts
Top