Ford Power Stroke Nation banner

1 - 20 of 30 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Recently bought a 96 7.3l with 305xxx on it. Was told the transmission would not shift properly. Seller said he was told the valve body was bad. So I bought the truck because I have a spare transmission and we replaced the valve body. The truck will still only go 40 mph. We also found a dead short in the wiring. Could a speed sensor be causing this?
 

·
Native Texan
Joined
·
8,987 Posts
Recently bought a 96 7.3l with 305xxx on it. Was told the transmission would not shift properly. Seller said he was told the valve body was bad. So I bought the truck because I have a spare transmission and we replaced the valve body. The truck will still only go 40 mph. We also found a dead short in the wiring. Could a speed sensor be causing this?
That year truck uses the same speed sensor as the dash so not likely exactly what is it doing is it not shifting out of second. I had a problem with my 97 e4od not shifting out of second. these trans had a problem with the 2-3 shift valve sticking so they made a steel replacement. Also could be a problem with the solenoid pack.

"Y'all have a wonderful"
"My name is Bob the guy floating in the lake with no arms and no legs"
TSGT Bob W Martin USAF 1948-2014
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Yes not shifting out of second. Replaced the solenoid pack with the valve body. Could it be the torque converter?
 

·
Native Texan
Joined
·
8,987 Posts
well like I said the 2-3 shift valve is a known problem. the torque converter won't prevent it from shifting.either something is wrong with the wiring to the solenoid pack which should set a code in the pcm or the valve is sticking. I fought with mine a lot till I put a steel shift valve in.

"Y'all have a wonderful"
"My name is Bob the guy floating in the lake with no arms and no legs"
TSGT Bob W Martin USAF 1948-2014
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
Solenoid pack came out of the good trans. Thought we could save time by just transferring everything over but trans might just be bad.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6
Replaced the vss on the rear end today and the same stuff is going on so might just have to bite the bullet and replace the whole thing.
 

·
Native Texan
Joined
·
8,987 Posts
Solenoid pack came out of the good trans. Thought we could save time by just transferring everything over but trans might just be bad.
Replaced the vss on the rear end today and the same stuff is going on so might just have to bite the bullet and replace the whole thing.
My trans came out of a running driving truck did nothing to the 2-3 shift valve but it still started sticking. I would not condemn it till you looking into the shift valve if the trans was worn out it would try to shift and slip. it not shifting is exactly what mine would do. have you tried to have the codes read to see if there are any. Like I said check the wiring external to the trans going to the solenoid pack if the signal never gets to the pack then I cant shift.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #9
Also found a plug on the transfer case that was broken. Not sure if that would cause it. Tried plugging it in and still nothing. Will check voltage on it tomorrow along with the other plug going into the solenoid pack. What should the voltage read or how do you check for a bad plug?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #11
Found a truck at a you pull it lot but it's a gas burner didn't know if everything would work properly or not
 

·
Former Ford Trans Engr.
Joined
·
3,043 Posts
Diesel only. The gas and diesel harnesses are very different.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #13
Thanks for your post mark. Talked to a tranny shop Friday and got a few more leads. They told me to turn the truck on and unplug the main harness going in and then go look at the o/d light to see if it was blinking if it wasn't then he said I might have a bad PCM. It was blinking so I proceeded to replace the neutral safety switch and is still doing the same thing. Is there any other options I can try before putting in the new trans?
 

·
Former Ford Trans Engr.
Joined
·
3,043 Posts
Have you read the codes? The new trans might not fix the problem. If the problem is bad info being sent to the PCM a new trans won't fix it.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #15
Have not seen any codes yet. Next step is to take it somewhere and have it read with a fancier code reader as mine is not very fancy.
 

·
Former Ford Trans Engr.
Joined
·
3,043 Posts
After you change the transmission if it's still doing it (and I think it will be) we can help diagnose what's really wrong.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #20
Ok thanks. So it sounds like it's fixable then? Just was starting to worry about chasing my tail and dumping thousands of dollars into it. Thanks for your post.
 
1 - 20 of 30 Posts
Top