Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
I was just wondering, my automatic trans has been freshly rebuilt, nothing special, just went through new converter, and i my temp is running about 190 degrees running through town, kinda stop and go traffic, im not pulling anything or running my chip, its all in stock settings. The outside temp is 98 degrees and higher humidity. Is this normal or bad, im gonna get a tru-cooler in a couple of weeks to go on it.
 

·
Registered
Joined
·
454 Posts
thats not too bad, but i went with the 6.0 cooler and deep sump pan when i did my rebuild. with outside temp about 90-95* regular stop and go driving trans temp has yet to reach 160*. loaded or towing have not seen over 200* im sure when you are loaded or towing a load you will be well over 200 and thats not good for an extended period of time. not too sure how the tru cool compares to the 6.0 cooler, but i love how mine has made a huge differance in trans temp. hope this helps.
 

·
<-- GO BRONCOS
Joined
·
965 Posts
That temp is normal for an ambient air temp of 98°. Trans temps should be 80-100° over outside air temps.

I would skip on the tru-cooler and get a 6.0 tranny cooler, in my opinion it is a much better cooler.
 

·
Registered
Joined
·
68 Posts
Discussion Starter #4
Ok thanks alot guys, i was just worried i guess, i would really like to find a manual trans for it, but they not easy to come by.
 

·
One man wolf pack
Joined
·
423 Posts
something tells me my gauge aint even working, its been over 100 here lately and my gauge hasnt moved off of 100 at all. anyone got any ideas. most of my driving is stop and go. this is the trans temp gauge i have

 

·
Registered
Joined
·
1,434 Posts
Check your power box and grounds
 

·
One man wolf pack
Joined
·
423 Posts
im gonna check the wiring tomorrow. the gauge lights up when i turn the lights on, all of my gauges are piggy backed onto one wire running to a power source.
 

·
One man wolf pack
Joined
·
423 Posts
ha ha never mind i figured it out and well im embarassed:doh:
 

·
Registered
Joined
·
3,940 Posts
Care to share???
 

·
Registered
Joined
·
2,438 Posts
I have a second small cooler and run 150-165.
 

·
Registered
Joined
·
3,940 Posts
On my early 99 there's no cooler in the rad so I added a trucool along with the stock one. Pulling the trailer, 12+K, on 6% grades in 100* temps barely reaches 180*. Reg driving here in town with temps around 117*, stop & go around 180* trans temp.
 

·
Registered
Joined
·
3,381 Posts
You 180 sounds about normal.....On my sig truck with e-fans, stock rad and v10 tranny cooler in front bumper with auxilliary fan on it hardly goes above 150 city driving on highway 130 fans off. Off road with lotsa slow first gear with fans on 180. Have not towed the TT yet looking forward to though. Ambient air temps 25-38 Celsius (80-105 F there bouts). I had looked to install the 6 oh cooler but as I run an IC it left very little room so I went with the V10 and thus far very pleased.
 
1 - 12 of 12 Posts
Top