Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
I have been having a issue with my trans and cant seem to figure anything out exactly what the problem is. I have a spartan with the newest 310 update and had the 275 on it until recently. But when accelerating hard, the tranny/engine revs up in between 2-3 and 3-4 and slames into gears pretty hard. It did this on the 275 and since the 310 it does maybe even worse. Since the 310, driving normal the engine revs up and skips into 3. Its pretty weird?? I replace the fluid and filter and the pan was spotless. I have got a code twice but my dumbass clears the codes before writing them down but it was something about a solenoid sticking or shut. Also it goes into limp pretty often and sometimes wont go into 5 gear. Also you stop and turn the truck off and then back on it will go into 5th. Ihave kind of read in here of people replacing a solenoid and that fix it?? Any suggestions is greatly appreciated.
 

·
Former Ford Trans Engr.
Joined
·
3,124 Posts
I see your photo, but if you told me the year of the truck I might be able to help.
 

·
Former Ford Trans Engr.
Joined
·
3,124 Posts
Having the codes would help a lot.

It could be a solenoid, or it could be something with the programmer. Having the codes that are stored would go a long way towards diagnosing what's wrong.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #5
Yea Mark its a 2008 and i know i should have kept the codes. i know it said something about a solenoid stuck open or something. ill get it to come up again and save it
 
1 - 5 of 5 Posts
Top