Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Etaylor0056
Joined
·
206 Posts
Discussion Starter #1
Ok, First off, I have a late 08 F250 4x4 80k Auto with H&S XRT PRO, DPF Delete and EGR blocking plates. Truck has all ways ran great and shifted without any issue. Truck is very very powerful with these few mods. The other day I was going to drive the truck to church and was the first time the truck has been ran in over a week and a half. Drove the truck like normal and everything was shifting and running fine. Went to pull a hill that it typically climbs in OD and lugs right up it with no trouble and no down shift. About mid way up the hill my rpm raised to about 2200 like I had broke traction and was spinning on the wet pavement. Let off of it and got back into it and the same thing occurred but this time I realized that it wasn't because of a lack of traction. Seems that my TC wasn't locking like it was suppose to. Automatically looked at the trans temp and seen that it was normal and not hot. Checked under the truck to make sure fluid wasn't leaking out. So on my way home I found that the truck shifts like its suppose to but will not stay locked into OD. Mid way home shutdown the truck, Uploaded another file from the tuner and no difference was made. The codes that I have found on the scanner are p0741, p1744 and p008c which are clutch solenoid circuit performance, and torque converter clutch performance/stuck on. The 008 one is a fuel cooler i think.
I'm going to pull the pan this pm and find out what the fluid looks like and the magnate in the drain plug. If i do not find anything strange in the pan then whats the case of just a solenoid going bad or just stuck?
My main question is, What steps do i need to take to trouble shoot this issue. I have found several good threads but seems that everyone is very breif and does not go into detail about the issue and where to find parts and how to trouble shoot it.
Please post links and Videos here and then this thread might possibly help someone in the future who has this same issues.
 

·
Etaylor0056
Joined
·
206 Posts
Discussion Starter #2
I'm also going to post this in the Trans Forum to try and get a diversification in answers.
 

·
Registered
Joined
·
545 Posts
If you can replicate the problem while logging or watching the torque converter % slip on your h&s, it should be 0% once locked if it anything more the converter is going bad and will need to be replaced, it would be a good idea to look at the trans once it's out also...
 
1 - 3 of 3 Posts
Top