Ford Power Stroke Nation banner
1 - 5 of 5 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
I have a 2003 F-350 with a 7.3L, I have had 4 pedals go out on me in the last three months. They start off working fine, 1/4 inch of movement and RPMs rise. Over the last weeks it has taken more pedal to make the RPMs go up. Over an inch. Once you put a new pedal in it it works fine for another month. When the pedal would fail it just stays at idle. It starts doing in say 1out of ten then it goes to eight out of ten. Any ideas.
 

·
ARMY bound
Joined
·
6,989 Posts
I had the same issue with my truck at one time. It drove me nuts figuring it out but it ended up being the PCM. It started happening slowly, left me stuck a few times, but the PCM was my problem.
 

·
<----Colin Banks
Joined
·
3,001 Posts
Hey Ryan... If you want to, I will give you the PCM out of my EX. We can get it tuned for your truck by sending it to DP Tuner and then see if that is the issue. Let me know what you think. Seems weird that the PCM would be frying throttle pedals. But then again stranger things have happened.
 

·
<-- it's like that
Joined
·
6,567 Posts
You don't happen to have anything tapped into the accelerator pedal do you, like an 18K mod or something else? The reason I ask is that the 2002's and 2003's with the adjustable pedals tend to not like those kinds of mods.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #5 ·
I had a "powerstroke exaust brake" tapped into the red wire. When it would read voltage through this wire it would open the EBPV. I took it out of the truck, to see if it was causing it.:confused:

P.S. No adjustable pedals.
 
1 - 5 of 5 Posts
Top