Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
ok..i have a 2003 f350

installed a 2005 6.0 i did the black onyx head gaskets and the arp head studs

its been running great for months..

the light on the dash came on for air filter replacement...i replaced the air filter

i towed my enclosed trailer to the track,about 80 miles away...got out and the truck and trailer was covered in oil..about 4 quarts low...

so i had a buddy tow my trailer home and we cleaned the motor and all with brake cleaner and it never leaked a drop the whole way home following my buddy

the second i overtook him and built boost it started leaking again...

ok...i think it was a valve cover leak..

NOW when you start it ,it sputters and pours white/blue smoke out the exaust and if you rev it up it cleans itself up and runs fine..once in a blue moon at a traffic light it will sputter and white/blue smoke comes out

it still has all the power and seems to run fine...has no coolant in the oil or looses pressure when you pressurize the system...any ideas?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #2
also i have the sct programmer and have been playing with it in max performance mode and i had it in tow mode when i was towing the trailer..
 

·
Registered
Joined
·
22 Posts
My engine was never covered in oil but it sounds similar to what was going on with mine when the turbo went. I replaced with a Powermax, no smoke, runs great.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
has there been any loud pops losses of power?

when i first installed the motor the og turbo popped and lost all power...i know that "pop" lmao...i replaced it and it ran fine for months...plenty of power..

now it sputters and smoke pours out of it...also had a some oil blow out the glow plugs...i pulled the glow plugs and the oil was on a pice of cardboard that i had layed up there to see..
 

·
Registered
Joined
·
33 Posts
Discussion Starter #8
ok i pulled the tune out of it and put it back stock setting...it doesnt smoke anymore but it also doesnt seem as powerful as it was before i used the sct tuner...

any ideas?
 

·
The Unseen Mod
Joined
·
4,126 Posts
You need to put it on a scanner and see whats she doing across the board. ICP, cylinders etc. Oil in the glow plugs has me curious.
 
1 - 9 of 9 Posts
Top