Ford Power Stroke Nation banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone. I've been working on this one for a while now and am stumped. Just looking for any help. 03 with 137k miles. Two months ago the transmission was having issues so I had it rebuilt by a shop. When done, I drove it for about a week and it puked it's trans fluid all over the ground. So, back to the shop. They called and said the transmission had some power going through it as it welded the transmission pump and welded the torque converter to the input shaft. That was fixed and I drove the truck home. The next day, I fired it up and drove it to work. On the way, it was bogging and bucking at stoplights. Like the torque converter was locking up on it's own at idle. Also felt like missing and down on power. I replaced the ficm with a reman and also did a new injector harness. No change. The truck starts and runs like nothing is wrong, but as soon as you put it in reverse or forward, even manual 1, the torque converter locks and it kills the truck (It feels and looks like the engine is under a huge load). I've cleaned the PCM and transmission harness connectors with no luck. Could it be a bad PCM?

It also has an issue where it drains the batteries after a week. Sometimes less. And the speedometer goes crazy if I pull the abs fuse. The speedo will follow the tach as the rpms climb. Less so when the headlights are on.
 

·
Registered
Joined
·
4,946 Posts
It is probably stalling because of low transmission line pressure. Check it with a gauge. Unlikely it’s the tcc itself. You need a new trans shop that one isn’t working for you.

Shoot me a PM if you’re looking for a different builder.
 
1 - 2 of 2 Posts
Top