Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
PSD6.0
Joined
·
6 Posts
Discussion Starter #1
Hello,
I have an 04 excursion 6.0 with MBRP 4" exhaust- no cat, no muffler and AFE cold air kit. Under light to moderate acceleration (especially up a grade) I'm getting a surging boost. I haven't noticed if RPMS fluctuate but it's noticeable in the exhaust note. If I back off or give it more pedal it goes away. Idles fine and I haven't noticed a loss of power but it's definitely annoying. Anyone have any input? Thanks!
 

·
Banned
Joined
·
2,444 Posts
Do you have any diagnostic codes?
Do you have a way to monitor VGT duty cycle?

Sent from my Smart Car
 

·
Registered
Joined
·
104 Posts
These threads are common, I asked almost the same thing when I signed up (mine did the same thing). Injector stiction is one possibility. If you want to investigate sticiton, just read the other threads on this forum. There are lots of posts all about it.
 

·
PSD6.0
Joined
·
6 Posts
Discussion Starter #8
Sorry I'm new to the forum and this is my first diesel. I got the excursion early November and it seemed to do it less when warmed up. Temps are definitely a lot colder now and it does it both when cold and after warmed up. Runs fine otherwise. There's just that area of mid throttle acceleration where it's very noticeable. Doesn't miss or buck just a smooth up and down surge. Probably a bit more noticeable since I put the exhaust on- maybe just because it's louder. Don't have a scan tool but it was recently at the shop and came away clean as far as I know. Shop told me it was from the deleted EGR but I'm looking for other thoughts. I don't think it should be acting like this. Thanks guys
 

·
Banned
Joined
·
2,444 Posts
The further closed the veins are commanded, the lower the duty cycle.

Sent from my Smart Car
 

·
Banned
Joined
·
2,444 Posts
Can't say. Depends on the tune.
Mine stays around 70% (75 is max) at idle but has only gone down to 35

Sent from my Smart Car
 
1 - 11 of 11 Posts
Top