Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Stirn Again
Joined
·
75 Posts
Discussion Starter #1
This has happened twice now when we have a heavy rain
the truck stumble /hesitate and kinda jerk like it is transmission related
i have replaced the cps after the first time and the truck actually just died
while in motion going around a corner:doh:
Have had no problems until today we had some heavy rain and on the way
home from work it died after start up while leaving the parking lot.
Threw it to neutral fired right up. Proceeded to drive home nothing for about 10 miles then a little jerking motion and all is fine then as i am coming up the hill to the house mild acceleration it hesitated/jerked and engine light comes on
oh i thought i can read a code turn truck off get scanner to check code
engine light is off and no codes found. It also seems to act up when cruise is on in wet weather
It only does this when there is a monsoon going on it seems like something is getting wet

Any ideas
 

·
Registered
Joined
·
2 Posts
I am having the same type of issue. only it will do it anytime, not only in rainy or damp weather. and it will sometimes die when sitting at an idle. I changed the CPS and ICP and this helped for about a month or so. But the problem came back yesterday. I am at a loss. :doh: anyone have any ideas?
 

·
Registered
Joined
·
98 Posts
check any connections to the icp and all harness connection at the rear near the fire wall . take them apart and silicone them . i had issues on my 6.0 the previous owner had broken the clips to the ficm harness and it would get moisture in .
 

·
Stirn Again
Joined
·
75 Posts
Discussion Starter #4
As doublesrtroker said in his post i did some wire wiggling today after i pulled the truck on ramps went to start it would only crank hmmm! What did i do retraced my steps wiggle wire on IPR then try to start it and it starts. Pull off the connector and the wires are bare about a 1/2 inch under plastic loom right as they feed in the connector can you say possible shorting out from engine vibration looks like the wire is almost ready to fall out of the connector. Taped them up truck fired right up,
It reminds me of when the nut backed of the IPR and fell into the valley. when you would take off the sleeve would slide on the IPR and lose contact and truck would die let off gas fire it up and ran fine. Almost the same symptoms
Now we wait for the monsoon to see if it really was the problem

Goodluck
 

·
Headwind Magnet
Joined
·
626 Posts
I would check the IDM in the DS front wheel-well. Mine actually had water in it. Pull it out, give it a shake and listen for water.

Unfortunately, its not the most weather-proof location for a computer.
 
1 - 5 of 5 Posts
Top