Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter · #1 ·
I am new to these 6.0's and started working on a Lot of them at work now, so needless to say, I think I will be on here alot! Lol! Ok I am working on a 03 6.0 with a cold hard start and big lack of power, ficm has 47.9v oil pressure good. The concern is my eb readings, they fluxuate between 4-65psi at idle. When stalling the engine they go upwards to 200 psi. Made sure the eb tube was free of blockage and also replaced the eb sensor. Possible stuck viens in the turbo? I can watch the datastream on my scanner and see the duty cycle change? Well thanks in advance guys!!!! Hope fully I get good at these 6.0s!!!
 

·
Registered
Joined
·
181 Posts
Discussion Starter · #2 ·
Well the viens on the turbo atent stuck. And I'm lost as what it is! Just lacks low end power and doesn't like to idle on cold start.
 

·
Haters Gonna Hate
Joined
·
5,868 Posts
will it build boost fine? when my cat plugged on mine it had no power at all on the low end and would only build about 11 psi of boost, id hate to see what the bp looked like
 

·
Registered
Joined
·
181 Posts
Discussion Starter · #4 ·
Ya it builds boost, took the cat off and watched the bp numbers and it didn't make a big difference, so I pulled the turbo apart to check te viens and nothing there either
 

·
Captain Negativity!
Joined
·
3,108 Posts
It's in turbo learn mode. It's actuating the vanes and reading the flow through the MAF sensor. If you have an aftermarket intake on it, it will do it forever. If you have the stock one on it, it just hasn't finished yet or something else is skewing the results its looking for.

So.... It's normal.
 
1 - 6 of 6 Posts
Top