Ford Power Stroke Nation banner

1 - 10 of 10 Posts

·
Registered
Joined
·
454 Posts
Discussion Starter #1
truck and mods are in sig. it starts and runs great, as im driving it feels like im switching tunes between 80 economy and 120 race. i normaly run in 120 race tune, its extreamly noitcable and the best way to describe it is its switching tunes on its own. any help would be great. thanks
 

·
Village Idiot
Joined
·
8,209 Posts
Is your chip taped in..
 

·
Registered
Joined
·
454 Posts
Discussion Starter #3
dont remember installed it about 4 years ago and havent touched it since. ill ck it. any other ideas?
 

·
Canadian Eh
Joined
·
675 Posts
Mine kind of surges when the cruise is set and i have the chip set to anything but stock, i dont notice it anymore but it drives my old man nuts when he's in the truck
 

·
Registered
Joined
·
454 Posts
Discussion Starter #5
Mine kind of surges when the cruise is set and i have the chip set to anything but stock, i dont notice it anymore but it drives my old man nuts when he's in the truck
ya its real strange, some days it will do it all the time and some days it wont do it at all.
 

·
Registered
Joined
·
454 Posts
Discussion Starter #6
can it be the icp or crank sensor? i got to figure this out its getting annoying!
 

·
Registered
Joined
·
3,940 Posts
swap the cps and see what it does. Borrow one if you can. And secure the chip. I don't think that's it though. If the chip was losing contact I think it would fry and may fry the pcm. I know about that, lol
 

·
Registered
Joined
·
454 Posts
Discussion Starter #8
last night i noticed the battery light was flashing intermitantly, but the voltage gauge didnt seem to change. can my problem be a voltage issue? today the truck is running/driving fine.
 

·
Registered
Joined
·
298 Posts
low voltage makes em do crazy things. Check your connections and if posssible get your batteries load tested and you alternator bench tested. Any advance auto can check em.

Will
 

·
Registered
Joined
·
454 Posts
Discussion Starter #10
up date. still having this same issue, changed alt, tested batteries, no more batt light flashing intermitanly. is there anything spacific i should look at on the scanner while driving the truck?
 
1 - 10 of 10 Posts
Top