Ford Power Stroke Nation banner

1 - 15 of 15 Posts

·
Who is Obama?
Joined
·
1,780 Posts
Discussion Starter · #1 ·
So I've had this problem for quite a while now (about a year) and for some reason waited till now to ask about it... But to the point...

So when I blew my stock turbo I threw in a 62mm River City non vgt, and promptly got custom tunes from matt to go with it. Now ever since then, most of the time if I just mash on the throttle, when it hits higher rpms, it will sound as if the engine is bouncing off the redline. Now if I roll into the throttle until I am just about to the floor, it doesn't usually do this, but overall hard acceleration will usually yield this strange occurrence. I had Matt try to tune to fix it, but it didn't do anything and I don't think the tunes are the issue, and I also got a walbro inline pump just incase psi was low, and now don't drop below 48 psi ever, but I haven't done anything else. What could this possibly be??

Thanks!
-Scott
 

·
The Unseen Mod
Joined
·
4,123 Posts
When you start going above 4200 rpms sorta maxing it out really, plus also you start to loose your power band at those rpms. Stock Valve train doesnt like being that high I believe.
 

·
Registered
Joined
·
583 Posts
What is your rev limiter set to in the options on your programmer?? Might simply be set a little too low for whatever reason and you are actually bouncing off the rev limiter.
 

·
Who is Obama?
Joined
·
1,780 Posts
Discussion Starter · #6 ·
Rev limiter is set at 4150. I am programming it right now to the tow tune to see if there is any difference up top. It's not near redline when it does it, it usually will do it for about 4 seconds when at wot, shift and will stop for about 2 seconds and then start bouning again once the rpms come up a little more. I have not tried other tuners with this turbo, but I had innovative tunes before and it did not do this. Could I be running out of fuel?
 

·
Captain Negativity!
Joined
·
3,108 Posts
See if someone went a little crazy with the IPR duty cycle. Datalog the ipr and see if its bouncing off of 99%
 

·
Who is Obama?
Joined
·
1,780 Posts
Discussion Starter · #8 ·
So the ipr was at about 95% and spiked at 99.61% under 4000 rpms. In tow mode it was max of about 85% and ran very smooth. So now what do I do?
 

·
Registered
Joined
·
583 Posts
So the ipr was at about 95% and spiked at 99.61% under 4000 rpms. In tow mode it was max of about 85% and ran very smooth. So now what do I do?
Get some new tunes, maybe from a different vendor
 

·
Captain Negativity!
Joined
·
3,108 Posts
So the ipr was at about 95% and spiked at 99.61% under 4000 rpms. In tow mode it was max of about 85% and ran very smooth. So now what do I do?
Someone wasn't aware of not needing full pump to get to the pop off in the ipr. Do what is suggested below.

Get some new tunes, maybe from a different vendor
 

·
ΜΟΛΩΝ ΛΑΒ&
Joined
·
3,067 Posts
Someone wasn't aware of not needing full pump to get to the pop off in the ipr.
IYO what is the intent to running it that way? I guess why would you want the IPR to pop off while accelerating?


You can view this with the X3?
 

·
Registered
Joined
·
5,346 Posts
Let me know what the ICP voltage is doing under WOT and I can correct it if that is the problem. Some trucks do indeed not need the full IPR DC. Fuel starvation can cause a similar symptom.
 

·
Who is Obama?
Joined
·
1,780 Posts
Discussion Starter · #15 ·
Just thought I would let you guys know that Matt is helping me fix up my tune and has been very prompt with his help! He has successfully fixed the problem and now we are just sorting through a little shifting problem, but the flutter is gone. Thank you Matt!
 
1 - 15 of 15 Posts
Top