Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
On my 2010 6.4 the alarm lately has constantly been going off.

Usually is is within a short period after shutting down and locking the truck but it also does it at random through the day.

It has a pioneer double din receiver and it is tuned with sct. Tunes were reverted back to stock once and the problem didn't clear.

Any ideas?
Thanks in advance
 

·
Registered
Joined
·
115 Posts
Discussion Starter #2
had to disconnect the horn due to the frequency, now everytime i look outside the truck is glowing and flashing like a Christmas tree
 

·
Registered
Joined
·
380 Posts
Can't say this applies, but I had a Crown Vic that this happened on a few years back.

I ended up disconnecting the battery and leaving the headlight switch on overnight, it was fine the next day. Something was just 'glitched' in the security system, and resetting it overnight seemed to fix it.

Other than that, it may be a switch or sensor someplace.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #4
i tried disconnecting battery once but i hooked it right back up, maybe ill give the overnight reset a try thanks
 

·
Registered
Joined
·
380 Posts
Leave something on, like the headlights.

I know the one in my Vic only reset if I let it drain completely, almost like there's a tiny battery someplace storing some information, something like a CMOS battery on a PC.

It never acted up again, was a pain in the ass though.
 
1 - 5 of 5 Posts
Top