Ford Power Stroke Nation banner

1 - 20 of 23 Posts

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #1
Well I know this subject has been beat to death but I can't handle it any more!
Here is a list of what I have done.
Changed;
P/S pump,
all the lines,
steering box,
both hub bearing assamb.
With in the last year;
Spicer ball joints and all new tie rods.
Also tried a different hydro boost. and different wheels off a stock f350
I still can't turn when not moving! I know this is "normal" But the truck is 8 years old and it has been fine to turn up till the last month. I have bled the chit out of it. 35 times back and forth with a rubber glove over the fill cap. Still nothing. What could have changed in the last month to made it hard?? I love my truck but if I cant fix this I cant see any reason to keep it. I need to turn when not moving to back up my fifth wheel. :( If the truck was like this from day one I wouldnt be asking for help. Please PSN guru's help! my wife has to drive this truck everyday.
Thanks
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #3
NO dice. Does not change. If I am on a smooth concrete floor it will turn when not moving.
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #6
Could it be a caster problem because my front leafs sagged? (stock suspension)
 

·
PSN Pretender
Joined
·
1,926 Posts
Nahhh.....sagging springs might cause caster to go a little negative which would actually make it easier to steer. That is assuming its a SD and the shackles are on the rear of the springs.
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #8
Had the ball joints done at a reliable front end shop. And they have been good for almost a year then all of a sudden hard steering. It is the truck in my sig.
It did not change at all. worse or better when I changed pumps. So I dont think it is the pump. All the stuff I listed did not change it at all. Better or worse.
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #10
New pressure reg.
 

·
PSN Pretender
Joined
·
1,926 Posts
Not sure where to go from here....... I would get a pressure test to be sure the pump/reg. is OK.

Sorry I couldn't be more help
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #12
Thanks for the time anyways!
 

·
PETE ENGR PSD
Joined
·
973 Posts
No noises at all/groaning etc? Have you pulled your reservoir at all for the P.S. and looked for metal shards on the screen in it?

Kinda off topic but my PSD came from the factory with a bunch of hair in the p.s. system. I accidentally pulled off the wrong line one time, and I pulled out a clump of hair nearly the size of my fist. (I had chewed through 3 p.s. pumps). A year later no problems so far.
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #14
You can hear the pump load up when you cant turn. The wheel goes half a turn then rock solid. And the pump starts to whine. With all the new parts and lines I have changed I don't think there is anything left in it as far as blockages. I am going to try come shims in the front suspension between the axle and the leafs. I think my leafs sagged and changed my caster. I am going to try and drop one degree in caster and see if it helps. Like I said I can turn better on a smooth concrete floor so I don't think i will need to loose a lot of caster. Still open to ideas. And thanks to everyone that has read this and also responded.
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #16
No dice. When they were done they were not all done at the same time. When I did the p/s pump I changed the line from the pump to the hydroboost. Then when the steering box was done I changed the rest of the line's.
 

·
PETE ENGR PSD
Joined
·
973 Posts
Sounds like a bad power steering pump, even though I know you don't want to hear that. Have you flushed the system to see if that would help? Where are you getting these P/S pumps? Online? Ford?
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #18
From my local parts store. I have been through so much atf! flushing it is an understatement. I am going to try getting another pump and see if it changes anything. It is making the same noise my stock one did when this problem started. It did not make it worse or better when I changed pumps. Not the slightest change! 8 years of working fine and now it wont turn? I am not going to settle with thats the way they are! Something changed? Just need to find it!
 

·
They call me Nobody
Joined
·
258 Posts
Tire wear has a lot to do with it. Hydro assist and be done! Turning with one hand is nice even when sitting still.
 

·
Canadian Stroker
Joined
·
577 Posts
Discussion Starter #20
Where do you get a hydro assist from? I tried rotating my tires tried different pressures and tried low mile stock 06 wheels no help.
 
1 - 20 of 23 Posts
Top