Ford Power Stroke Nation banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
INSTALLED A NEW STEALTH SRP1 ON MY MILDLY MODDED EARLY 99 7.3
NOW IF YOU STOMP ON THE THROTTLE IT FALLS ON ITS FACE HARD THEN YOU HAVE TO LET UP ON THROTTLE AND SLOWLY EASE INTO THE THROTTLE TO GET A SMOOTH HARD ACCELERATION. TOO HARD AND IT FREAKS OUT,

THOUGHT IT WAS THE 6 POS TC CHIP SO I TALKED TO MATT (GEARHEAD AUTOMOTIVE) HE THOUGHT TUNE WAS SPIKING PRESSURE TOO FAST, TOOK CHOP OFF STILL HAS THE ISSUE.
SCANNER SAYS 2450 MAX OIL PSI...
K&N INTAKE
TC CHIP
4 INCH EXHAUST
BUILT TRANS
SRP1
38R
FASS 95GPM
ANY IDEAS WOULD BE SWEET!
:bowfast:
 

·
Registered
Joined
·
4,865 Posts
First can you turn you caps lock off that it makes it a royal PITA to read.


Did you install a new IPR or replace the o ring etc when you did the install? Many times and this was seen with the Adrenaline as well people end up with a dirty or worn out IPR or orings and from taking it out it finally causes the issue to show. Personally going from a original HPOP I would install a new IPR as part of a new HPOP install.

Also may want to make sure what you are seeing from the stupid PCM and ICP sensor is actually the pressure with a mechanical gauge. It could be the ICP sensor has gone bad.

Also when you log your ICP you always need to log a duty cycle % as well as that can help point to where the issue may be.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
i believe the duty cycle was around 7 at idle and 30? at WOT. if i remember correctly
 

·
Wheelie Dude
Joined
·
2,126 Posts
With that DC doesnt sound like the pump is the problem. Make sure the gear bolt is tight and the gear is not slipping, other then that sure sounds liek a poppet valve coming open on an injector.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
it was the ICP sensor, plug had a bit of oil in it giving the pcm a false reading....
wow thanks to matt at gearhead for the tip!
 
1 - 5 of 5 Posts
Top