Ford Power Stroke Nation banner

1 - 19 of 19 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
hey has anybody had 6.4 start squealing sounds like a belt but its not, i was driving home the other evening and stop at light my truck just started squealing,i took both belts off and the noise is still there sounds like its coming from passenger side of the motor. could it be in the valve train,or a turbo has plenty of power and boost.oil presure is good also
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
no soot on the firewall,the noise just came out of nowhere really sounds like its coming from front of the motor. but iam not real sure.
 

·
Registered
Joined
·
151 Posts
This just happened to me.
I had my truck in the shop for t-stat R&R and they moved the turbo discharge pipe.
After driving, it has a loud whistle/sqeel sound.
It is a torn/cut/punctured boot.
Check your CAC boots for security and integrity.

Bill.
 

·
Registered
Joined
·
16 Posts
Mine has started doing it here lately after it turned cold (20-30 +/-degrees F) it only does it when it's cold but once the truck warms up it stops...same area front passenger side of motor. Haven't taken the belts off or anything but ill check all the things you guys mentioned. Just started about a week ago and you can barely hear it when driving but defiantly when idling. Sounds like a power steering pump squeal. Truck has just over 46k miles. Hei69racing have you found a solution?
 

·
Registered
Joined
·
3 Posts
I'm a new diesel owner, 2008 F-350, I don't know much about them. I have a squealing noise as well. It's coming or sounds like its coming from the top passenger side of the motor. I'm thinking bad bearing in turbo. Not sure which one though. Am I thinking the right part???? Has anyone had it checked. It doesn't do it at idle. Just makes the noise at about 8 pounds of boost. Can anyone help me. Yes, both belts and tension pulleys and idler pulley have been replaced. Noise still there!!
 

·
Registered
Joined
·
264 Posts
RH up pipes are pretty common for leaking around that mileage. Usually leak around the flex joint. If you get a good flash light and a mirror, you should be able to see it, just look for black soot marks. Also check for exhaust manifold bolts broken or missing. See if you can see soot around the exhaust ports. I know its almost impossible to see on driver side but again good light and a mirror.

On the other side of things, could be a small tear in the cac boots as well.
 

·
Registered
Joined
·
119 Posts
Had the same noise on my truck come up Wednesday afternoon checked everything y'all mentioned and nothing... Let the truck cool over night popped the hood Thursday morning and checked for soot on firewall or anywhere it's not supposed to be and nothing. Started it and ran my hand around turbos exhaust manifolds and up pipes before the motor warmed up and still couldn't find anything. Went for a drive and at 2400rpm and up it would squeal pretty lound. Pissed me off so I kept mashing on the little skinny
 

·
Registered
Joined
·
119 Posts
Pedal. Went home and let it cool a few hours and cooled down myself lol went back out and popped the hood. This time I found lots of soot on the passenger side of the fire wall after doing some looking with a mirror and feeling with my hands I found a bolt head missing on the up pipe connecting directly to the turbo. I was able to get the remaining part of the bolt out with my hand. Went to ford picked up a few of them suckers and replaced it. Has anyone else had this happen?? What could have caused it. The turbos were replaced in January
 

·
Registered
Joined
·
124 Posts
Possibly the bolt was over-tightened creating a fracture and the heating/cooling cycles caused it to pop.

Mine has a squealing noise intermittently too. I think it's the A/C belt and tensioner though. Mine only happens at idle and just slightly off idle.

Glad you got it figured out though.
 
1 - 19 of 19 Posts
Top