Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
461 Posts
Discussion Starter · #1 ·
I have sent several PM's to owners that I have researched on the board by searching threads etc and have not received a response. I assume you are all unhappy with the tuners or could not care less about responding to someone with questions. I have a few questions that when I have searched through forums and company websites etc, have not been answered.

*Does the Spartan monitor and display TQ and HP like the H&S?

*Are you satisfied with your Spartan 6.7 tunes? Overall Spartan satisfaction?

*How is the drivetrain management on the Spartan? I heard there was another release coming out but it seems Spartan owners do not post often.

*What parameters are monitored and can be changed by Spartan (TPMS etc)?

*Any experience with the H&S and the Spartan on the 6.7 for an overall review of what you liked better?

Thanks in advance. -Steve
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Still have my phone number?
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #3 ·
I do (at work) and you have been helpful, I appreciate that.
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
I try my best
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Update comea out today
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #6 ·
And you are pretty much the only owner I have heard from.
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Lol ill let you know how the update is this weekend
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #8 ·
Please do.
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Less boost, ran 14.4 on the warhammer tune. Going back to the 165 tune, hope they didnt chabg that tune as i was running 14.1 with it
 

·
The new dude
Joined
·
195 Posts
Well that's no good if they all turn out this way. Is there anyway to go back on the Spartan tunes to the previous versions of a tune? Just out of curiosity what tune do you get your best mileage on?
 

·
<-- Fat Bottom Girl
Joined
·
871 Posts
Im back to the 165 tune, running 14.1 again
 
1 - 12 of 12 Posts
Top