Ford Power Stroke Nation banner

1 - 10 of 10 Posts

·
Science rulz
Joined
·
1,424 Posts
Discussion Starter #1
The truck's a 2000 7.3 with an edge evo, stock sticks with just around 100k miles on 'em.

I find this pretty weird. I have an edge evo which has been sitting in the 100 hp tune pretty much all the time for a year now. In the beginning as I remember it would roll a good bit of coal at WoT and at if you rolled into the throttle while in lockup. Now it barely smokes at all. I find this strange, the truck still runs good, no weird noices or nothing...

The EGT's have rarely been over the 1000 mark and just once above the 1200, it seems to be running pretty cool actually. Usually it stays at around 5-600 while cruising at 50-60 mph.

Any ideas if this might be signalling something wrong? Or if it just means I've blown all the soot outta my turbo? :hehe:
 

·
Registered
Joined
·
920 Posts
HPOP getting tired?
 

·
owner/president
Joined
·
2,768 Posts
Edge is ruinin your motor and tranny.
 

·
Registered
Joined
·
1,018 Posts
:whs:
 

·
Registered
Joined
·
1,434 Posts
HPOP getting tired?
A tired HPOP would result on poor fuel atomization which in tuen equals more smoke.

Unplug the chip then plug it back in. Try that
 

·
Science rulz
Joined
·
1,424 Posts
Discussion Starter #6
Engine and trans feel as good as they was when I installed the chip *shrug*

But I'll try to return it to stock, with the road conditions the way they are it's kinda hard to keep the rear end on the straight and narrow..
 

·
Registered
Joined
·
920 Posts
A tired HPOP would result on poor fuel atomization which in tuen equals more smoke.

Unplug the chip then plug it back in. Try that
I disagree, a tired HPOP would also change how much fuel is injected.

To the OP, check the tech section on how to check HPOP output.
 

·
Registered
Joined
·
3,940 Posts

·
Science rulz
Joined
·
1,424 Posts
Discussion Starter #9
Have it scanned and toss that edge before you spend big $$$$.
The Edge is going, however I just can't afford throwing any parts at my truck that it don't need right now.

Set it back to stock yesterday, apart from loosing the extra grunt it had it feels pretty much the way I remember it. Transmission seems to shift a bit softer then I remember though :shrug:

Wish someone had a scan tool, but even the dealer here doesn't have the right tool... Quite surprising since this is one of the places with the highest density of these trucks in the country. Pulled a couple of codes with the edge, can't exactly remember what it was but it wasn't something important.
 

·
owner/president
Joined
·
2,768 Posts
Probably overboost or ICP codes.
 
1 - 10 of 10 Posts
Top