Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
damn thing goes out every 2 years or so. Im tired of having a 5spd OBS
 

·
Registered
Joined
·
448 Posts
ummmmmmm does this thread have a point?
 

·
Registered
Joined
·
65 Posts
Discussion Starter #3
just tired of it always breaking. I dont even tow anymore bc this truck always fails. anymore smartass comments?
 

·
Registered
Joined
·
757 Posts
My 5SP is original. Never had to change anything. 130,000 Miles.
 

·
What else?
Joined
·
4,156 Posts
damn thing goes out every 2 years or so. Im tired of having a 5spd OBS
Have you replaced the whole hydraulic system together, or do you keep buying just the slave? It's very difficult to bleed the air out if you just get one of the pieces, that is why Ford offers the whole system as a kit, pre-bled. Also I've had to replace a couple clutch throwout forks, they bend sometimes.

Also you need to see if your pedal box bushings or the linkage pin bushings are wore out, they are known to cause issues also. There's a reason why Ford offers a pedal box bushing kit and the clutch linkage mod is on eBay.

Judging by your sig line you also have an issue with the trans itself? I would guess synchro issues? I've had to replace a few zf5's for that reason.

Dave
 

·
Built without your taxes
Joined
·
290 Posts
HA! every 2 years? try every month. my plan and advice to you is if your clutch still grabs, replace the fork, bearings, master and slave and buy the tie rod linkage mod off ebay to replace the p.o.s bushing set up. Thats my plan at lest once i buy a new Sbc.
 

·
Death Row Inmate #7
Joined
·
1,458 Posts
Dude, why come on here and bitch when obviously there is something else causing it to go bad?! when that truck came new do you thing it went through slaves like that? no. when something keeps going out then there is another reason for it. like are you using the crappy ones from like autozone or equivalent parts stores? if so start off w/ a brand new pre bled clutch master and slave assymbly, change the clutch fork, take a good look at the ball that the clutch fork pivots on, change the throwout bearing, and look at the sleeve that goes around the input shaft that the throwout bearing slides on. chances are that sleeve is probably worn and is causing the throwout bearing to try to slide at an angle and creates too much stress for the slave to handle. The slave is probably blowing fluid out of the housing if i had to guess.... i went through 13 slave cylinders in one year. guess what? the Ford slave cylinder is about twice the size(diameter) of the crap i got from the autozone, orielys, and advanced auto parts... no problems with this one and my clutch fork was all screwed up and was goind crooked when i pushed the clutch..
 

·
Registered
Joined
·
65 Posts
Discussion Starter #9
My 5SP is original. Never had to change anything. 130,000 Miles.
Im jealous

Sounds like bad luck! Only thing I have replaced is my clutch. Everything else is strong at 271,000
wish I had the same luck

Have you replaced the whole hydraulic system together, or do you keep buying just the slave? It's very difficult to bleed the air out if you just get one of the pieces, that is why Ford offers the whole system as a kit, pre-bled. Also I've had to replace a couple clutch throwout forks, they bend sometimes.

Also you need to see if your pedal box bushings or the linkage pin bushings are wore out, they are known to cause issues also. There's a reason why Ford offers a pedal box bushing kit and the clutch linkage mod is on eBay.

Judging by your sig line you also have an issue with the trans itself? I would guess synchro issues? I've had to replace a few zf5's for that reason.

Dave
I had the entire hydraulis system replaced Jan 22, 2008 at Pheonix Transmission in Weatherford, Texas. (about 35 miles from ValAir in Mineral Wells) That was just over 200,000 miles. All these new problems have happened since the valair was put it. Seems like Im the only person who has trouble with it tho on this forum. Pheonix Transmissions only had bad things to say about Valair also, has encouraged me to get an SBC. Thanks for all the feedback guys
 

·
What else?
Joined
·
4,156 Posts
Trust me, you're not the only one with PSD manual tranny problems, I've had the displeasure of fixing a fair share of them myself.

You've just hurt the manual tranny guys' feelings, they don't like having to admit the zf's aren't perfect.

If it's since the Valair was installed, I would be pulling the trans back out to see if you can find what went wrong, it sounds like possible installation error, or the fork bent, I'm leaning toward the latter.

Dave
 

·
Shortbus driver
Joined
·
223 Posts
I'd keep a spare slave in my parts bin and carry on :D

Havent had any problems with mine.... even if I did, its real easy to change. Never had a problem bleeding the system.
 
1 - 11 of 11 Posts
Top