Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
I have industrials twin kit with an S474 as the big turbo. It seems like it is a little slow to light. It really won't light until about 2200 rpm and with my tire size and gearing, that speed is about 80 mph. I am running elites 185s. Would it be benificial to downsize turbos to say an S471. Thanks for any advice.
 

·
Subject Matter Expert
Joined
·
4,458 Posts
What is the specs on the small turbo? The big turbo will only be driven as hard as the small one is pushing it. Chances are you need to drop down in size on the secondary (smaller) turbo to get quicker spoolup across the board to drive the atmosphere (big) turbo quicker
 

·
i like to party
Joined
·
1,415 Posts
Powerstrokejunkie is right

Not sure if you have Industrials tow or race compounds but seeing you have the s474 ill assume you have the towing setup, which secondary do you have the 62/70 or the 62/80?

If you have the 62/80 the spoolup will be a good deal slower than the tigher .70 housing put a bd diverter valve to help spoolup of the 62/80..

The primary will only light if the secondary is lit...
 

·
Registered
Joined
·
67 Posts
Discussion Starter #4
I do have the 62/70 and it lights well enough. For example, cruising down the road at say 70 mph and 2k rpm with little load, I will build about 7 or 8 psi and be smokey at near or over a 1000 degrees. Now pick up the rpm another couple hundred, you can hear the big turbo light, and clear the smoke and still only be building 7 or 8 psi with close to a 800 degree temp. Hope that helps. Thanks for the input
 

·
Registered
Joined
·
1,963 Posts
I was thinkin the same thing. Those II twin kits have been known to have leaks. I've heard it mentioned already from guys who have had them. Leaks from the poor weld job and nothing lining up the way it should.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #7
I am one of the people that has been talking about the leaks. I have fixed multiple leaks, exhaust and oil drains. I do not have any oil or exhaust leaks now or boost for that matter. I do have 185 injectors though. I will attempt to change some tuning and see what happens. It was way different when I had the tow tune in it. Of course since then, I have had the turbos off about five times. I will figure it out. Thanks for the feedback.
 
1 - 8 of 8 Posts
Top