Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2,761 Posts
Discussion Starter #1
I'm borrowing my friend's 01 7.3 (140K on it) while my truck is in the shop. While I was driving the other night, the CEL comes on, loossz power, begins missing and the trans starts to shift hard.

When the truck starts, it smokes bad and keeps on smoking bad (blue smoke, smells like up burnt fuel). It was 60* out. It starts fine. Just today the OD light starts to flash. Don't know if it's related to the motor. My friend runs red fuel because he gets it for free (don't even ask). When the truck first starts, it runs fine. As it warms up, it runs on one bank

I scanned the truck, forgot the codes but there were codes for high boost and driver side bank open or shorted. Also there was a code for the IDM and ECM shorted. The EGT probe is in the driver side manifold and it was reading 0.

I have an OBS 7.3 so I'm familiar with the 7.3 but need tips on the SD. I know that the UVC harnesses come off. And wire harness that goes over the valve cover rubs through. Any other areas to check?

Thanks

Billy T.
[email protected]
 

·
OEM Moderator
Joined
·
9,381 Posts
Billy I think you are gonna need those codes or run buzz test on it.
 

·
Registered
Joined
·
2,761 Posts
Discussion Starter #3
Billy I think you are gonna need those codes or run buzz test on it.
It failed the buzz test for the driver side bank which I knew it was going to. The driver side injectors didn't buzz.

What has me baffled, the truck runs fine when cold then misses once warmed up. How long does it take for the IDM to shutdown to protect itself if there is a short in the inj harness?

Billy T.
[email protected]
 

·
Registered
Joined
·
191 Posts
I just went through this ... 2 days ago . I had to pull both valve covers and when i opened them the connectors/pig (uvch) tail was not connected ... did the 25 cent mod.

My truck runs like a champ now. I wasnt always getting a ses light, missed after warm up, pulled the codes... the passanger side bank was basically dead ... took me 3 hours all said and done im know mechanic by any means...

Just a thought good luck

Brev :psnb:
 

·
Registered
Joined
·
574 Posts
i just had the same thing happen to my 02
driver's side bank had two faulty injector/idm codes
Replaced UVCH and wire harness all is good now!
 

·
Registered
Joined
·
2,761 Posts
Discussion Starter #6
Update

I took off the driver's side valve cover and everything looked fine, nothing burnt. Put everything back. Checked the wiring on top of the engine and everything appeared to be fine.

Saw oil by the ICP plug. I unpluged it and the ICP cavity was loaded with oil. I replaced the ICP and replaced the pigtail. I doubt the ICP had anything to do with the miss.

I pulled down the driver side fender well and swapped out the IDM. I swapped in my modified IDM. Shoved the fender well back and went for a ride. Took it for a ride and everything ran fine.

Now I have to get my friend to buy an IDM. Anyone have any luck with the $159 rebuilt IDMs on E-Bay?

Oh yea, it's much easier working on my OBS than the SD.

Billy T.
[email protected]
 

·
Registered
Joined
·
191 Posts
I personally do not electronics off ebay ... to many sponsors to get things like that from... I agree prices are good, but ive heard stories on some of the remanufacured/moded IDMs from ebay ... just my opinion ... glad your rig is rollin... Brev
 

·
Registered
Joined
·
267 Posts
Billy call Dave at SWAMPS. its like 250. for the moded IDM with a core. or they can take a look and fix the one you have.
 

·
Registered
Joined
·
284 Posts
Billy call Dave at SWAMPS. its like 250. for the moded IDM with a core. or they can take a look and fix the one you have.
X2!!!!...

I would NOT purchase the ones from the place in Florida that advertises on E-bay... Auto Computer Exchange....
Several months ago, I posted a thread on here about that place and everything we went thru with them...
In the end, I called Swamps diesel, they sent one right out, truck was back running the next day...
Auto Computer Exchange.. Buyer BEWARE!! - PowerStrokeNation : Ford Powerstroke Diesel Forum
 

·
Registered
Joined
·
2,761 Posts
Discussion Starter #10
X2!!!!...

I would NOT purchase the ones from the place in Florida that advertises on E-bay... Auto Computer Exchange....
Several months ago, I posted a thread on here about that place and everything we went thru with them...
In the end, I called Swamps diesel, they sent one right out, truck was back running the next day...
Auto Computer Exchange.. Buyer BEWARE!! - PowerStrokeNation : Ford Powerstroke Diesel Forum
Unfortunately he ordered an IDM through them. I told him the places to get one. But he says he'll take his chances with the $159 one.

Some people just don't get it. We'll soon find out.

Billy T.
[email protected]
 

·
Registered
Joined
·
2,761 Posts
Discussion Starter #12
1 - 12 of 12 Posts
Top