Ford Power Stroke Nation banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey guys, I have a 95 f350. When I start the truck the "check engine" light comes on but will idle fine. When the engine light goes off the truck will die, if I hold the gas pedal down about 2k rpm's it will stay running but will idle rough. I replaced the cam pos sensor but still does the same. If I try to drive the truck with the engine light on it will bog real bad and try to die. Any ideas? Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Oh I'm sorry. I use my phone to post. I'm not sure on the fuel pressure, I don't know much about these engines at all. I do know its bone stock, if that helps. Sorry, this just started happening out of the blue
 

·
Registered
Joined
·
2,449 Posts
start by making sure you have enough oil in the crank case. these trucks use oil at high pressure to fire the injectors, and if you don't have enough, it will cause what you describe.
if you have adequate oil, and it's still not running right, my next thought would be to check fuel pressure. in the center of the engine, there's a fuel bowl. on the side of the fuel bowl is a schraeder valve that you can use to check the pressure. you're looking for 40-50 psi minimum, preferrably around 65.
if that's good, I'd start the truck,wait for this to start happening and go unplug the ICP sensor. it's a little plug on the front of the driver's side head. if it's reading incorrectly, it can cause issues.
try these and get back to us so we can help you.
Dan
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top