Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
OBS Roller
Joined
·
250 Posts
Discussion Starter #1
When I turn the key to the run position to cycle my glow plugs the #2 relay constantly resets itself, creating a clicking noise. I can crank but it will not start.However if i continue cranking long enough the relay will finally turn on and i get power to the IDM, it will start and run like a champ. Has anybody had this problem occur before. Hopefully if I get any answers I can look tomorrow, if not it wont get done till next friday.:doh: Thanks, Stefan.
 

·
Registered
Joined
·
3,026 Posts
The only time I saw this was when one of my brother-in-law's batteries internally shorted. Have your batteries load tested and make sure the cable are disconnected from both when its done. If one battery is bad, change them both. Also check all the battery cable connections (battery side and the other ends as well) to make sure they are clean and tight. You can also try swapping relays in the underhood fuse box (swap relays 2 (IDM) and 3 (Horn)). Cheers!
 

·
OBS Roller
Joined
·
250 Posts
Discussion Starter #3
The only time I saw this was when one of my brother-in-law's batteries internally shorted. Have your batteries load tested and make sure the cable are disconnected from both when its done. If one battery is bad, change them both. Also check all the battery cable connections (battery side and the other ends as well) to make sure they are clean and tight. You can also try swapping relays in the underhood fuse box (swap relays 2 (IDM) and 3 (Horn)). Cheers!
I tried swapping relays. And the batteries are only 4 months old. Ill try to clean the connections good and see what that gets me. Thanks!
 

·
Registered
Joined
·
290 Posts
I had a wierd issue like that too. It was clicking, and the truck was a no crank no start. I unplugged the suspected relay, and the truck turned over, but with no IDM control, it wouldnt start.

I swapped relays, and it has been fine ever since.
 
1 - 4 of 4 Posts
Top