Ford Power Stroke Nation banner

1 - 13 of 13 Posts

·
Registered
Joined
·
5,464 Posts
Discussion Starter #1
It has an intermitant deadspot in the throttle, I ordered a new pedal assembly but now im having second thoughts on that being the problem. At cruising speed engine loses enough power it feels like a fuel pump shut off, so I put a fp gauge in cab and thats not the problem. The power loss is more obvious when cruising in the extreme vs econo program. I havent pulled chip and driven it that way yet, should I try that? Any ideas on what to check? Ive got to get this figured out before I leave tomorrow, not to fond of being stranded on hwy somewhere in western KS or eastern CO
 

·
Registered
Joined
·
6,652 Posts
Does it go away immediately when you floor it?

I has a dead spot and inermittent miss and very light throttle and it was the IPR in my case.

If you've changed injectors or anything recently the IPR is suspect as well, it only take a TINY obstruction to screw with it. You might try pulling them and cleaning. I can get you instructions/pics if you haven't done it before.
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #3
yeah it goes away when i floor it. If i had a snap on scanner hooked up what would i look for?
 

·
Registered
Joined
·
6,652 Posts
that's a good question.

I would start with ICP, ICP(V), TPS%, and IPR duty cycle.

ICP, and ICP(V) should jump around if it's an IPR issue, as well and duty cycle, although duty cycle tends to move slower.
Compare those values, especially duty cycle, when it does it, and when it's smooth. If duty cycle is way higher when it has the flast spot, that would indicate to me the IPR is trying to close there and can't, or if it's way lower could be building too much ICP?, maybe.

I would think TPS% would go funky at the time it happens too, but I've never personally watched a bad one on the scanner.

hope that helps
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #5
pulled the chip and it didnt fix it. As of now i dont think its tps, just a little bit ago i pulled out of driveway and it took 1-2 seconds to do anything after i mashed the throttle.
 

·
Registered
Joined
·
6,652 Posts
wierd....
I would look at TPS% if you can get a scanner. That should tell for sure on the pedal. Sounds like that could be it.
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #7
i dunno what the problem was/ is, but no troubles on the 7.5 hr trip out.
 

·
AllYourBaseAreBelongToUs
Joined
·
13,954 Posts
PCM or tuning?:swordfight:

J/K!:D

Glad you got it worked out.
 

·
Fat Kids Rule!
Joined
·
2,455 Posts
my truck did that once, dead pedal then all of sudden it would play catch up and do everything you tried to do why it was dead at once, turned out the ecm was junk!
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #12
took awhile to figure out... now none of you fools buy/ bid on pcms over on ebay lol.
 
1 - 13 of 13 Posts
Top