Ford Power Stroke Nation banner

1 - 18 of 18 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hasn't run since. I've worked on it every day for the past 30 days. Been using all the great help & ideas in this forum. But still no start. I really need my truck running. Any ideas will be appreciated.

To date I've replaced the fuel pump, new filter, blew out the return & supply lines & removed the injector device attached to the fuel filter & cleaned it. It cranks w/ white smoke evident. I got one or two pops today with heavy cranking but no start. Ive been approaching the problem as trash in the fuel system.
 

·
DieselAddict
Joined
·
63 Posts
SOunds like a pain so far... Make sure your fuel bowl is full of fuel, also make sure your HPOP res is full. If you're getting white smoke that means you're getting fuel. How cold has it been? All fuses intact? Tried jumping the GPR for 30 seconds then try cranking? Unplug your ICP try cranking.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Hpop res filled, It's summer in N.O., Checked the fuses & relays. Thanks for the next steps. I was stumped.
 

·
Registered
Joined
·
5,959 Posts
The first thing to check when you don't get the wait to start light is the #22 fuse under the hood. Don't just look at it but test. If it is bad then unplug the fuel heater line on the drivers side of the fuel filter housing it is the spade type connector about in the middle. Replace the fuse and see what happens.
 

·
Registered
Joined
·
5,373 Posts
^^^^ And DON'T just replace it. Common cause of fuse 22 failure is the fuel heater shorting out. You should disconnect it first before replacing the fuse; otherwise it'll just blow another one.

S-WAG - when the fuel ran dry, the fuel heater was still running but with no fuel to heat, it overheated and shorted out, blowing the famous #22.

Hate to say it, but that should've been the first clue to follow, rather than throwing all those parts at it.
 

·
It likes 4400 rpm!
Joined
·
409 Posts
Also plug it in for ####s and giggles
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Sorry Guys, I'm new to the forum & just bought the truck. The WTC light is working, :poke:
 

·
It likes 4400 rpm!
Joined
·
409 Posts
If its smoking its getting fuel! plug it in and see what happens
 

·
Premium Member
Joined
·
7,509 Posts
Dumb question but are you sure it ran out of fuel?
 

·
Premium Member
Joined
·
15,561 Posts
Dumb question but are you sure it ran out of fuel?
:whs:

If your getting white smoke then your getting fuel. Fuse #22 should be good if your getting a WTS light. Is your tach moving while cranking? If not change the cps

I almost wanna say it's your cps since your said it quit running but wont fire.
 

·
Premium Member
Joined
·
7,509 Posts
:whs:

If your getting white smoke then your getting fuel. Fuse #22 should be good if your getting a WTS light. Is your tach moving while cranking? If not change the cps

I almost wanna say it's your cps since your said it quit running but wont fire.

If there is smoke there is oil and fuel
 

·
Registered
Joined
·
8 Posts
Discussion Starter #16
Thanks for the tip. The tach moved ever so slightly. I have a WTS light.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #17
It started running very badly. The gauge was on empty. But U could be right. Low rpms, it killed at the station, very hard to start, when it ran for the last time it would kill under 1000rpm & would not go over 2000rpm.
 

·
Premium Member
Joined
·
7,509 Posts
Have you checked all your VC harnesses?
 
1 - 18 of 18 Posts
Top