Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Truck ran great this morning, pulled into job, running fine then went to leave, no start. Checked DTC's and found P0303, P0307, P0308 which I believe are mishire codes plus a cylinger #4 contribution/balance code. 1600 miles on fresh build but I reused the FICM. Oil pressure is fine as well as fuel PSI at 50. Programmer had ICP voltage and IPR % the same as when it ran well. FICM voltage is 49-50. I am thinking the FICM has failed but would like opinions Please. Chris
 

·
Registered
Joined
·
30 Posts
Truck ran great this morning, pulled into job, running fine then went to leave, no start. Checked DTC's and found P0303, P0307, P0308 which I believe are mishire codes plus a cylinger #4 contribution/balance code. 1600 miles on fresh build but I reused the FICM. Oil pressure is fine as well as fuel PSI at 50. Programmer had ICP voltage and IPR % the same as when it ran well. FICM voltage is 49-50. I am thinking the FICM has failed but would like opinions Please. Chris
How many RPMs while cranking? Did you check for fuel? Are your batteries in really good shape?
Always start with the basics and move your way up from there.

Sent from my Vivo XI PLUS using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Truck started at the end of the day after sitting for 8 hours, didn't run great but started with no problem, HPO leak? I have new HPOP, new stand pipes and orings.
 

·
"resident smarty pants"
Joined
·
4,088 Posts
Sounds like a leak in the high pressure oil system. You need to post some data (in addition to answering
"6_Riders" 's questions).

Preferably when it won't start .....
Post cranking data:
Cranking rpms (need 150 minimum)
FICM sync (a FICM can be bad even with good voltage)
FICM VPower
FICM LPower
ICP sensor volts
ICP pressure
IPR % duty cycle
Fuel (Injector) Pulse Width
V-reference voltage

Also ....

50 psi for fuel pressure is the minimum IMO (even tough Ford states 45 psi). Even at WOT the fuel pressure needs to be above that value. You didn't say what engine conditions you got 50 psi at, so I assume it is at idle and not WOT. If so, then the pressure is too low and could be putting the injectors at risk.

As far as HPOP's go there is a lot of junk out there (and that includes OEM pumps). Some people have had bad OEM HPOP's - right out of the box.
 
1 - 4 of 4 Posts
Top