Ford Power Stroke Nation banner
1 - 16 of 16 Posts

·
I like turtles
Joined
·
2,604 Posts
Discussion Starter · #1 ·
My brothers truck is having problems. When he turns off ignition and step out of tuck radio and electonics stay on when they should turn off. And auto headlights don't work. Wasn't bad at first but now new batteries are dead. Have checked all fuses and tried relays. Any ideas
 

·
Super Hauler!
Joined
·
3,882 Posts
got the same issue with my truck, only does it every 3rd or 4th time i shut it off though. then sometimes randomly it comes on.
 

·
Registered
Joined
·
1,209 Posts
what year are the trucks? sounds like a power delay not shuting off at the right times. Had an early 6.0 come in doing this and it ended up being the BCM
 

·
I like turtles
Joined
·
2,604 Posts
Discussion Starter · #4 ·
03 in my brothers. His stays on everytime
 

·
Registered
Joined
·
1,209 Posts
certainly sounds like it to me. The one that I worked on failed ever time too. Find out what relay is the power delay relay, under the dash, I can't remember which one, and see if everything goes off
 

·
Registered
Joined
·
249 Posts
vsm or gem do a search. i have the same problem but have not fixed it.
 

·
I like turtles
Joined
·
2,604 Posts
Discussion Starter · #7 ·
Ok I will have him see if thats it in the morning. If anyone else has a clue let me know. thanks
 

·
I like turtles
Joined
·
2,604 Posts
Discussion Starter · #8 ·
His truck don't have one he said.
 

·
Registered
Joined
·
249 Posts
are the door locks acting up?
 

·
PETE ENGR PSD
Joined
·
972 Posts
His truck don't have one he said.
His truck has one. Also check the door switches. Re-check the relay for delayed accessory. Try spraying contact cleaner in the door switches and slamming/opening the doors numerous times. Generally its the driver door.. Are there any electronic mods on this truck (off road lights, radio etc?)

The GEM modules are a pain in the ass to get to, and their expensive. So try doing the simple things first.
 

·
I like turtles
Joined
·
2,604 Posts
Discussion Starter · #11 ·
It ended up being the safety electric module
 

·
Registered
Joined
·
249 Posts
did he fix it? if so what did it cost him, if you dont mind...
 

·
I like turtles
Joined
·
2,604 Posts
Discussion Starter · #13 ·
650 bucks 150 for part and 500 for labor and reprogram. He would not wait for my response and gave me false info on it. Radio did turn off but everthing else was acting funny. His lose not mine.
 

·
Word
Joined
·
608 Posts
Ford trucks and Expiditions had a bad problem with water leaking at the base of the front windshield and dripping directly onto the GEM and Fuse Block causing all sorts of electrical issues....see if the problem is worse when it rains....they may have found a victim of the water intrusion issue but not the root cause of the failure.
 

·
PETE ENGR PSD
Joined
·
972 Posts
Ford trucks and Expiditions had a bad problem with water leaking at the base of the front windshield and dripping directly onto the GEM and Fuse Block causing all sorts of electrical issues....see if the problem is worse when it rains....they may have found a victim of the water intrusion issue but not the root cause of the failure.

:whs:

I would continue to monitor that GEM.. Just out of curiosity how did yall confirm the safety module as the culprit?
 

·
I like turtles
Joined
·
2,604 Posts
Discussion Starter · #16 ·
he took it to the dealer
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top