Ford Power Stroke Nation banner

1 - 20 of 56 Posts

·
Registered
Joined
·
753 Posts
Discussion Starter #1
So i was racing a camaro today. (beat him) and after that my truck started making a noise out the intake... could it be a bent pushrod??? Or does anyone have any other suggestions? It does not seem to have a miss or at lleast not noticable..... please help
 

·
Registered
Joined
·
7,985 Posts
So i was racing a camaro today. (beat him) and after that my truck started making a noise out the intake... could it be a bent pushrod??? Or does anyone have any other suggestions? It does not seem to have a miss or at lleast not noticable..... please help
bent pushrod or broken rocker arm.
 

·
Registered
Joined
·
753 Posts
Discussion Starter #4
well thanks guys guess ill be calling swamps tomorrow. :evil
 

·
I like turtles
Joined
·
2,604 Posts
Id call this guy. David Lott
Super fast shipping, great prices and helps alot on forum. :rockwoot:
 

·
Waitin' on 500
Joined
·
2,109 Posts
Swamps will get him taken care of the same though.
 

·
I like turtles
Joined
·
2,604 Posts
DI is cheaper. :pointlaugh:
 

·
What else?
Joined
·
4,156 Posts
Pull the valvecovers first, and see what you need.

And if you order up pushrods, put springs in too, otherwise, don't even bother with pushrods.

Dave
 

·
Waitin' on 500
Joined
·
2,109 Posts

·
Registered
Joined
·
753 Posts
Discussion Starter #13
well the motor did not make it the 5 miles home last night!!!!! from my gf (where the comp is) to my house!!! i was just normal driving and started getting a clatter from the top end... went to pull over and before i could lost oil pressure motor shut off. and wont turn over... (not a rod knock i know what that is) have not had time to take valve cover off yet.... any new suggestions???? and who wants to build me a MOTOR???? :bowfast:
 

·
PSN Pretender
Joined
·
1,926 Posts
Injector came loose, crush washer on the bottom probably failed.

Have you recently had the injectors out?

Dont try and crank it anymore!

Pull the covers and all the glow plugs, then bar the engine over by hand and look out for the hole that shoots fuel out.
 

·
Registered
Joined
·
753 Posts
Discussion Starter #15
injectors have been in for about 8k miles but not to the kind of boost i was pushing last night..... i have had a inj come loose before so i kinda know what that is like and i dont think its that... from the noise it was making before it failed.....
 

·
PSN Pretender
Joined
·
1,926 Posts
So the motor does not rotate anymore ..............right?

Lets think of a few of the possible causes real quick:

  • Hydro-locked
  • Seized/ Spun bearings
  • Broke/ Bent Rod
  • Valve dropped in cylinder
  • Broken/ Seized Transmission Pump(Not very likely)

Which one of those most fits your situation?;)
 

·
Premium Member
Joined
·
3,060 Posts
let me nail this one...

bent pushrod = unloaded lifter = lifter slung off the cam lobe (broke the lifter retainer plate in the process) = lifter sitting in the lifter galley = LPOil pissing out the (empty) lifter hole = lack of LPOil pressure = DOA PSD

bank it
 

·
dinnerbooter treasurer
Joined
·
3,567 Posts
let me nail this one...

bent pushrod = unloaded lifter = lifter slung off the cam lobe (broke the lifter retainer plate in the process) = lifter sitting in the lifter galley = LPOil pissing out the (empty) lifter hole = lack of LPOil pressure = DOA PSD

bank it
:whs:
 

·
you want some of this?
Joined
·
2,922 Posts
let me nail this one...

bent pushrod = unloaded lifter = lifter slung off the cam lobe (broke the lifter retainer plate in the process) = lifter sitting in the lifter galley = LPOil pissing out the (empty) lifter hole = lack of LPOil pressure = DOA PSD

bank it
:whs:---maybe.........

But Dave, that dont explain the locked down motor..............:poke:
:D
LOL
 
1 - 20 of 56 Posts
Top