Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
467 Posts
Discussion Starter #1
I have 12,000 miles probly a little less.
On a 100% rebuild.
New Injector cups were installed..
I have had the Injectors in question out 2 times prior..

Heres the story.
I just pulled the injectors to get them gone thru..
I pulled the oil drain plugs under the VG prior to pulling them.
Once I pulled the 1st inj. I hear a glug, glug glug...
So I stuck a rag in the hole.. thinking it was fuel and hoping to catch it..
Just went to put it back yogether and figured I would try to get the Fuel out of the cylinder..
So I stuck a small piece of hose to a vac. pump and started sucking out the cyl.
And Coolant started comming out....

Could it be a Cup pulled up when I pulled the Injector??
I tryed to measure to see if It pulled up but dosant seen to measure differant...

I am at a loss what to do..
I have te guy that built the motor comming over this weekend to change out the 2 cups that are in suspect...
Any Ideas...

Didnt have any coolant loss prior to pulling the Injectors..

Id appricate any advise...
Thanks'
John
 

·
Registered
Joined
·
2,081 Posts
Might be cracked right where an oring would zeal it when installed
 

·
Registered
Joined
·
467 Posts
Discussion Starter #3
Thanks for the reply..
I guess Ill see Saturday when We pull them..:eek:
It is the first two cyl. on the Driver side
 

·
Registered
Joined
·
842 Posts
At least its the easy ones
 

·
Registered
Joined
·
326 Posts
I had one come loose on me when pulling the injecotrs for the first time since 95' and all the coolent drained into the oil pan! i was not happy but i was able to just put the injector back in and torque to spec...run it...then re-torque it and no problems yet..
 
1 - 7 of 7 Posts
Top