Ford Power Stroke Nation banner

1 - 17 of 17 Posts

·
Maroon truck guy
Joined
·
427 Posts
Discussion Starter #1
buddy of mine with 225s and a s300 66/74 has had problems with his truck puking at WOT. It only does it when its pulling hard and doesnt eat any coolant. I didnt think it sounded like blown gaskets because its not puking or eating any under normal driving. think it could be a cracked head or something besides the heads?
 

·
Maroon truck guy
Joined
·
427 Posts
Discussion Starter #3
he has a live wire so he cant monitor EOT right now. and he didnt notice any fuel in the coolant but he did find oil in it when he replaced the oil cooler recently. and hasnt pressure tested the coolant system yet
 

·
It wasn't me
Joined
·
1,232 Posts
he has a live wire so he cant monitor EOT right now. and he didnt notice any fuel in the coolant but he did find oil in it when he replaced the oil cooler recently. and hasnt pressure tested the coolant system yet
IIRC there is a update for the Livewire to monitor EOT.

I put my .000002 on HGs. Heads weren't machined correctly
 

·
Maroon truck guy
Joined
·
427 Posts
Discussion Starter #6
he just hasnt updated yet.

think its just a small leak that only leaks when the cylinder pressures get high?
 

·
Maroon truck guy
Joined
·
427 Posts
Discussion Starter #8
how did you coolant look?
 

·
BRING DA AMBALAMPS
Joined
·
1,952 Posts
Could be the cap too. I know Ford has a replacement that is supposed to prevent venting (if its not hg)
 

·
Car Ramrod
Joined
·
300 Posts
just had the same problem it was gaskets
 

·
Registered
Joined
·
695 Posts
It's the HG's. He can try to get a tune with less timing, that will fix it. I would pull the valve covers and check the tq on the studs. Crank them to 250lbs. Make sure peak timing never goes over 8*

don't let it puke or it will get worse, untill you get a new tune or re torque the heads don't run it at wot.
 

·
6.0..........
Joined
·
546 Posts
I have a similar problem could it be there is to much coolant in the reservoir ? It sits even or a little under the min line. I had arps and gaskets put in about three months ago. Ect and eot stay within 15. I wouldn't think I hope its not gaskets already.
 

·
Banned
Joined
·
1,378 Posts
It's the HG's. He can try to get a tune with less timing, that will fix it. I would pull the valve covers and check the tq on the studs. Crank them to 250lbs. Make sure peak timing never goes over 8*

don't let it puke or it will get worse, untill you get a new tune or re torque the heads don't run it at wot.
:whs:
 

·
burning mine saving yours
Joined
·
183 Posts
Yes its possible you have too much. The truck will puke out any extra, thats why they figured out the new levels, it was being overfilled. Mine will puke out exactly what it doesn't need due to the fluctuation in coolant under use. If i put in a hair too much, it will puke it out under wot. But thats just my truck, maybe different for yours.
 

·
6.0..........
Joined
·
546 Posts
Yea every trucks different. But mine has done it a few times, but its never a lot of coolant just a little bit. But I guess ill pull some out this weekend and go from there.
 

·
PSN Been daer dun it!
Joined
·
625 Posts
Sounds like a small HG leak. Only forcing air into the cooling system under high boost!!!
 
1 - 17 of 17 Posts
Top