Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter #1
So I just installed my street tune from swamps on my truck, had a lawn mower behind me on 12 ft trailer grasshopper mower. So about 2500 lbs maybe, go on the interstate and romped it to get up to speed the truck was nice till temp gauge climbed up and starting geting hot about two miles later. Shut the truck off and got out, antifreeze was all over the inner fender, detuned and a drove home. Im thinking whats up, truck had studs installed at ford and a new egr cooler about 10000 miles ago, and had no tuner till now. Any ideas :confused:
 

·
wheres the fat chicks?
Joined
·
1,833 Posts
blown head gasket
 

·
Registered
Joined
·
346 Posts
Discussion Starter #3
the truck is fine now, but I have no tunes on it, the temp climbed up thats when I noticed it puked all over,
 

·
wheres the fat chicks?
Joined
·
1,833 Posts
im surprised no one else has chimmed in yet.the title is prolly confusing
 

·
<-MONEY PITT!!
Joined
·
1,308 Posts
:whs: Did they check the heads good when they did the studs?
 

·
Registered
Joined
·
346 Posts
Discussion Starter #6
it was done before I bought it, but I do know the it was done by the dealer for one of the salesman it was his personal truck, the he asked about chipping his truck and what he need to do, they said install studs. So he did, I dont know if it was done right now. I have had no problems with any other tunes, just this one today only got to run about 5 miles total. I can say it run very well and I loved it, till I was on the side of the road with a temp light on. In the time it took me to detune and restart the truck the temp was normal after that.
 
1 - 6 of 6 Posts
Top