Ford Power Stroke Nation banner

1421 - 1440 of 1480 Posts

·
Native Californian
Joined
·
364 Posts
Don't, forget to share with others, ahem...LOL

Sent from my Pixel 2 XL using Tapatalk
 

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,422
Well I was suppose to go out on the 26th and come back the 1st, but inclement weather postponed us leaving until mid day the 27th, as the Tehachapi pass snowed over (in the middle of the desert, heh snowball chances in hell) on the 26th, and they shut down the pass in order to salt/sand and plow, but then the hundreds of cars already on the pass made it difficult. But, it opened back up on the 27th so we went for it.

We got all the way to tehachapi and found out they were still escorting people up the pass, and traffic was backed up to a stand still for close to 30 miles! So after waiting for 30-45 minutes or so, we opted for an alternate route through the 178, which led us up through Lake Isabella. Now, this was a tight, curvy road we knew, but it had been a long time since we've been that way last, and we had forgotten how bad it was... VERY TIGHT, and a rocky wall no more than a few inches away from the white line on our right, and a tight one-lane each way with a cliff on the opposite side made for some interesting maneuvering! Saw a Semi almost take out a Toyota SUV, and several occasions I came within inches of taking out some of the rock wall on out right side, but we came through unscathed.

We ended up turning a normal 2 1/2 hour drive into almost 6 hours!!! And many friends ended up staying in the line at Tehachapi for almost 5 hours themselves, so we ended up saving 3 hours or so taking the 178 through Lake Isabella.

After that, I became pretty ill, bad congestion, head pounding, ears wouldn't "pop" making my already bad hearing even worse, and couldn't sleep, couldn't interact with the kids or anything, we ended up decided to come home today, so we were only there for 2 nights, but it was still fun. Got to take our CanAm x3 out in the snow which was pretty cool. Shamu did great all the way there and back, never skipped a beat, and almost every hill I had the cruise set at 62mph and it never budged below it, although I've noticed with my new Jelibuilt tunes, they truck is more smokey than the Swamps tunes, to the point where my safety chains are completely black. Thankfully the whole front of my trailer is already black or else it would probably look much worse. Going to talk to Brian about that... Overall though, I'm very happy.
 

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,424
Finally, today came in my last present for the holidays, I swiped it from a guy on PSA, a brand new OEM engine harness, correct to my year and everything, gonna try and install it tomorrow, hopefully my illness is gone enough, I still have to wash and park the toy hauler too!

 

Attachments

·
Registered
Joined
·
1,320 Posts
Glad you are home safe, get too feeling better!!

Glad to hear the good news on the truck, sounds very promising. Impressive for sure.

Side note, I've been in a snowstorm in Needles, so Tehachapi isn't too much of a stretch haha!

Sent from my E6810 using Tapatalk
 

·
Native Texan
Joined
·
9,008 Posts
Me and the lady' in the snow with the X3, gotta be repping the DieselSite hoody :nerd:



Not what i expected you to look like

Sent from my SM-G970U using Tapatalk
 

·
Registered
Joined
·
2 Posts
trucks coming along amazing! happy to hear it performed well on your trip.

a side note though, I got a 95 f350 SRW 2wd, and I am swapping the 10.25 for the 10.5 some time within the next week or so. Now i really want to keep my factory Alcoa rims. When you do your 10.5 swap are you converting your bp to the SD or staying with the OBS?

Sorry if you addressed it in the past but I have not had enough time to read the whole post in its entirety.
 

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,428
trucks coming along amazing! happy to hear it performed well on your trip.

a side note though, I got a 95 f350 SRW 2wd, and I am swapping the 10.25 for the 10.5 some time within the next week or so. Now i really want to keep my factory Alcoa rims. When you do your 10.5 swap are you converting your bp to the SD or staying with the OBS?

Sorry if you addressed it in the past but I have not had enough time to read the whole post in its entirety.
I water jetted the 8x6.5 holes in between the 8x170 holes and pressed in new studs. I wanted to keep my wheels as well.
 

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,429
I got it installed today and it was a little stiff, but fit great. I have updated the EOT sensor so the pigtail is incorrect, and I have to swap the updated one to the new harness. But after the drive home, I can tell the truck definitely runs smoother in all aspects. Super happy!
 

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,430
Alright, I dont understand how, but this new harness has me flabbergasted at how quiet the truck has gotten! Out of all the mods I've done to quiet it down (thick coated valve covers, HPX, full exhaust with 30" FTE resonator, fuel sump and EFuel, T500 pump, etc), this has quieted it down the most. I actually had to turn DOWN the radio on the freeway today because it was plenty loud enough to hear!

I also got to test out the Drag Ripper tune from Brian, now that he stretched the shift points a little more, and it is awesome except for one easy thing. It bounces the rev limiter in 1st before going into 2nd lol, but then revs to a good 34-3500 shifting into 3rd, very good power curve and less boost drop in between shifts. The engine sounds good at that RPM too and dorsnt sound "wound out" like it's outside of the power band, but still pulls that last few hundred rpms.
 

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,431
Got under the truck tonight to check things out, and noticed my PS Pump pulley is rubbing the CAC tube... if its not one thing, its another!

 

Attachments

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,435
Lmao, I'm just going to try and reposition the pipe and throw a little tig weld over the gouge lmao.
 

·
Native Texan
Joined
·
9,008 Posts
Lmao, I'm just going to try and reposition the pipe and throw a little tig weld over the gouge lmao.
I would file a complaint with my fabricator over that snafu.

Sent from my SM-G970U using Tapatalk
 

·
Trust me, I got this...
Joined
·
1,354 Posts
Yea whoever put that together must have been a real bonehead Dan. I wouldn't trust them anymore LOL

Sent from my SM-J320V using Tapatalk
 

·
Project Shamu
Joined
·
2,465 Posts
Discussion Starter #1,439
Fixed the intercooler pipe today, pulled it out, sanded it down, TIG welded the gash, and then put a small dent in it as well. Then reinstalled and repositioned. Now it sits an easy 1" away from the pulley. Hope thats the last time I have to mess with that...


Me and a buddy also got bored, and he used to work at a body shop, so we spent some time aligning the fenders/doors and such, so that all the body lines were lined up nicely, and adjusted the doors to open and close easy too. Then we got a little more carried away and painted the holes on top of the roof left from the cab light removal. The previous owner pulled the lights, but I TIG welded the holes closed and never painted them, so they have just been getting a little surface rust over the last 6 years. We also sprayed the back of the cab where it got hit several years ago. We just hit it with a DA sander and sprayed the entire back edge of the cab. Surprisingly, the "Factory Match, Universal Black" is pretty damn close to my paint! The dent wasn't fixed, but it sure doesn't grab your eye from a bunch of missing/flaking paint any more.




When I pull the bed off to take to powdercoat, the same friend is going to come over and we're going to try and slide hammer the back of the cab straight, throw a little filler on there, and paint the whole back of the cab and the roof, I hope it comes out nice.
 

Attachments

·
Native Texan
Joined
·
9,008 Posts
You guys can come over and help with my cab beds already off glad u getting some good work done.

Sent from my SM-G970U using Tapatalk
 
1421 - 1440 of 1480 Posts
Top