Ford Power Stroke Nation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
201 Posts
Discussion Starter #1
Ok Powerstroke buds went up in inj. size there not real big put there on the large side..nothing changed but the inj.. I have drove the crap her.. thinking there was air it but its been 100s of miles no change.. here's the prob's im having...

#1 It tends to have a mis after putting her to the wood and has a sputer like there is still air in it??

#2 tends to have a blue haze like oil??

# idels a litte ruff?

Thanks for any help..
 

·
Registered
Joined
·
138 Posts
dont know but when i changed mine out it ran real rough and did some of the same things you are talking about till i got my chip tuned for the injectors then it all cleared up.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #3
I was thinking tunes but i had a top notch tuner do the tunes.. I need to call him.. and try some more tunes thanks alot for the input.. It dose alot of strange things..
 

·
Registered
Joined
·
138 Posts
mine ran real rough at idle and when you got in it it would cut out miss run real rough jonathon at beans reburned my chip and all was great so it might be what is causeing you the problem. good luck .
 

·
The Fireman
Joined
·
4,810 Posts
Pensacola injectors and DP tunes LOL

j/k but really it would help if we knew so we could help ya out better.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #9
Jim's inj.. and Tw's tunes... and i want all to know that bolth of them are the best to work with and very good at what thay do..
 

·
Custom Trailer Sales
Joined
·
6,161 Posts
Did you get all the injectors properly seated?

The first thing that comes to mind when you say, theres a choppy idle after a wot run is ICP.
 

·
The Fireman
Joined
·
4,810 Posts
Did you get all the injectors properly seated?

The first thing that comes to mind when you say, theres a choppy idle after a wot run is ICP.
:whs: Pull the valve covers off and put a straight edge across them and make sure they are all seated correctly.

Jim and Tony are good guys so I'm sure if there is something wrong with ether the tuning or the injectors it will get fixed.
 

·
Registered
Joined
·
201 Posts
Discussion Starter #14
Ok ill put a straight edge across them this weekend.. My 160's that i had in befor did go in with less effort than my new ones.. Thanks to all that have posted..
 

·
Registered
Joined
·
201 Posts
Discussion Starter #15
Ok i checked them out the other day they all were seated . So im thinking my tunes are off.. What would it run like if it had a split tunes??
 

·
Registered
Joined
·
201 Posts
Discussion Starter #16
And when i put it on HI-Idle its like its missing but if i use my ft. at the same rpm 1100 its fine..
 
1 - 16 of 16 Posts
Top