Ford Power Stroke Nation banner
1 - 9 of 9 Posts

·
6.0 Headache
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi Everybody

Im at a loss with figuring this out. My Truck will start up run perfect then it starts misfiring and then it get so bad and stall out. Sometimes white smoke sometime it doesn't. It does smell like raw diesel.

Now i have deleted the EGR. No coolant loss.

Fuel Pressure is holding 58PSI when is does stall.

The IPR is like 32% if i remember Correctly.

The ICP is reading normal. It goes up to about 900-1000 PSI when it stalls.

The Ficm Is 48V all through out.

I have done the bulletproofing myself. I did the HPOP and HPO Branch Tubes.

Also i get one code. P0269 - Cylinder 3 Contribution/Balance
But if i shut down that injector it does run different so i no the injector is working. I Hooked up a snap on modis and did a buzz test and it all checks out.

The only thing i can think of is Injectors But im not someone to throw parts at it and find out its not it.

Please any/suggestions are welcomed.
I really need Help with this thing.
 

·
Big dumb *******
Joined
·
4,200 Posts
having similar problem. i did a cylinder contribution test. cylinders 1,3,5,7 not working miss-firing. from what i know we both have to have a high pressure oil system problem. sorry to post no advice.
1,3,5, and 7 are on the same plug on FICM. I'd start there before I began replacing injectors. Not plugged in well, loose connection, etc...
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
:whs:^^^ Yep, that's what I'd look for first.
 

·
6.0 Headache
Joined
·
5 Posts
Discussion Starter · #6 ·
My HPO system is good. Ficm is good. I just down injectors and they all make a difference. Im gonna do the rubber glove test on the fuel lines today. I think I blew a copper washer out on the injector that's the only logical thing I can think of.
 
1 - 9 of 9 Posts
Top